ReduceConnectionsNet [ 06/12/23 Testnet] [Offline]

The last testnet was a certain improvement over the prior hiccups in the last month, but we’re looking to push things even further.

The main change here is aimed at reducing the connection load in nodes. We’ve two major strategies here:

  1. We reduce the number of nodes in the royalty-transfer topic, which reduces the overall connections significantly
  2. We have reworked how and when we try to redial nodes. This means we drop more connections more often, and increase the network knowledge to near idealised levels.

Local testing has shown quite drastically reduced memory, with heaptrack recorded “leaks” down from ~180mb a couple of weeks ago to ~18mb now (those leaks are ostensibly ongoing connectivity related memory).

Other changes:

  • Reduced replication down to 2* CLOSE_GROUP
  • Verification that replication messages come from a close node
  • addition of a wallet verify command to the CLI, to allow for CashNote verification
  • use of MsgPack instead of bincode for serialisation. (This will allow nodes/clients in any language, whereas bincode was rust specific).
  • more routing table / discovery tweaks
  • reduced verification waits
  • other chunk upload / payment fixes and tweaks

Network Details

Node version: 0.99.9
Client version: 0.86.44
Faucet url:

We have 101 droplets running a total of 2001 nodes. One droplet has 2vcpu and 4GB of memory.

If you are a regular user, see the ‘quickstart’ section for getting up and running.

If you are a first-time user, or would like more information, see the ‘further information’ section.


If you already have safeup, you can obtain the client and node binaries:

safeup client --version 0.86.44
safeup node --version 0.99.9

Run a Node





Check local node’s reward balance

Your local node’s peer id will be printed to the terminal on startup with an example command). (You can also retrieve this from the node directory.)

safe wallet balance --peer-id="<local-node-peer-id>"

Connect to the Network as a Client


safe wallet get-faucet
safe files upload <directory-path>


safe wallet get-faucet
safe files upload <directory-path>

To do this with non-default batch-sizes (along with SAFE_PEERS set as above):

safe files upload --batch-size 40 <directory-path> 

40 being the integer value you want to set

Further Information

You can participate in the testnet either by connecting as a client or running your own node.

Connecting as a client requires the safe client binary; running a node requires the safenode binary.

Obtaining Binaries

We have a tool named safeup which is intended to make it easy to obtain the client, node, and other utility binaries.

Installing Safeup

On Linux/macOS, run the following command in your terminal:

curl -sSL | bash

On Windows, run the following command in a Powershell session (be careful to use Powershell, not cmd.exe):

iex (Invoke-RestMethod -Uri "")

On either platform, you may need to restart your shell session for safeup to become available.

Installing Binaries

After obtaining safeup, you can install binaries like so:

safeup client # get the latest version of the client
safeup client --version 0.86.44 # get a specific version

safeup node # get the latest version of the node
safeup node --version 0.99.9 # get a specific version

safeup update # update all installed components to latest versions

When participating in our testnets, it is recommended to use a specific version. In our project we release a new version of the binaries every time we merge new code. This happens frequently, so over the lifetime of a testnet, many new releases will probably occur. So for participating in this particular testnet, you may not want the latest version.

The binaries are installed to ~/.local/bin on Linux and macOS, and on Windows they go to C:\Users\<username>\safe. Windows doesn’t really have a standard location for binaries that doesn’t require elevated privileges.

The safeup tool will modify the PATH variable on Linux/macOS, or the user Path variable on Windows. The effect of this is that the installed binaries will then become available in your shell without having to refer to them with their full paths. However, if you’re installing for the first time, you may need to start a new shell session for this change to be picked up.

Running a Node

You can participate in the testnet by running your own node. At the moment, you may not be successful if you’re running the node from your home machine. This is a situation we are working on. If you run from a cloud provider like Digital Ocean or AWS, you should be able to participate.

You can run the node process like so:

# Linux/macOS

# Windows

This will output all the logs to the filesystem, with the location of logs being platform specific:

# Linux
~/.local/share/safe/node/<peer id>/logs

# macOS
/Users/<username>/Library/Application Support/safe/node/<peer id>/logs

# Windows

If you wish, you can also provide your own path:

# Linux/macOS
SN_LOG=all safenode --log-output-dest <path>

# Windows
$env:SN_LOG = "all"; safenode --log-output-dest <path>

The advantage of using the predefined data-dir location is you can run multiple nodes on one machine without having to specify your own unique path for each node and manage that overhead yourself.

Connecting as a Client

You can use the safe client binary to connect as a client and upload or download files to/from the network.

Using the Client

You’ll first need to get some Safe Network Tokens:

safe wallet get-faucet

You can now proceed to use the client, by, e.g., uploading files:

safe files upload <directory-path>

To download that same content:

safe files download

This will download the files to the default location, which is platform specific:

# Linux

# macOS
/Users/<username>/Library/Application Support/safe/client/downloaded_files

# Windows

To download to a particular file or directory:

safe file download [directory/filename] [NetworkAddress]



If you’ve used previous versions of the network before and you find problems when running commands, you may want to consider clearing out previous data (worthless DBCs from previous runs, old logs, old keys, etc.).

# Linux
rm -rf ~/.local/share/safe

# macOS
rm -rf ~/Library/Application\ Support/safe

# Windows
rmdir /s C:\Users\<username>\AppData\Roaming\safe

If you encounter a problem running any of our binaries on Windows, it’s possible you need the Visual C++ Redistributable installed.


Ten nodes started, will update here as the test progresses.

Thursday: all nodes alive although two appear to be in a dessert (few PUTS / no earnings), max RAM 116MB (average 81 MB).

Saturday: I was busy Friday so the following snapshot is two days after the above, and I’ve included the whole summary and some observations this time.


  • No nodes have been killed and all are still active, because memory use is lower (88-181MB averaging 128MB) and my storage has not yet been filled up.
  • Connections: I don’t think I’ve ever seen anywhere near the numbers of connections (400+) some are reporting for this testnet. I’m pretty sure the connections for this testnet (156-174 averaging 166) are about the same for me as the previous test.
  • Earnings: there are the usual variations in storecost (53 to 12,531) and earnings (299 to 34,380).
  • Disk Use: I expect them to run out of storage unless I purge the logs soon though as I have only 2.7GB of free disk. Disk use per node is remarkably uniform with all ten using 2.1GB to 2.4GB before any purging:
2.2G    node/12D3KooWAGNkP6GntAkofa1jzR8yRwfv6jYxUDyXADsURcoPUaZW
2.2G    node/12D3KooWAhjrxE8C3om82FP8ueRYWP56cWdpxHTvbNVzbnXSaqZ5
2.2G    node/12D3KooWBcZL67vELDAzQEdLiG7xubr4g6fLQYvvUTZfp1wkxBtV
2.2G    node/12D3KooWFM848CUg4t1h56sS9pYRAvWjXvRsYBQWeHN7c9uq5LRW
2.1G    node/12D3KooWFoAtNaYFNU2JsAocv3MStPHTs89V9VxmyR2ngEn6pZDw
2.4G    node/12D3KooWG7Xc1DzywarnsW3k8TeSZjh9aZ8cSS8DSN2LFrnGqy1t
2.2G    node/12D3KooWGqXvWrsVECKfa3KM4YN8QPcMCDRKyPh8NPVqu4Ngb1w7
2.2G    node/12D3KooWKn9HZeNFWxkYW5sUfe8WPbiRM2Yf6EGVbyN71cvMyTfR
2.3G    node/12D3KooWLh9xxVNWuEJbi4Nh2NwM9QrmjqyrkQY9bNKgnxUD47zF
2.2G    node/12D3KooWSHVQGhW9TRbHyjcEu5rKBYvC2xg9DTRhsT4P99V4iT1U
  • Errors show an interesting variation is that all but 2/10 have less than 100 errors in the past 3 hours, and most are below 50. Yet two have over 750 errors in the past 3 hours, so that may be of interest as all nodes are running in the same cloud environment. @joshuef :thinking: The culprits were though the first two nodes started which seems too much of a co-incidence not to be a factor. However, while they do have more errors in total 9,312 and 12,976 (since start) than most other nodes the difference isn’t as great as in the past 3 hours. For all nodes the errors are 3,261 to 12,978 averaging 6,636. Also, even though the recent bump in errors in the past 3 hours is large, these errors were evenly spread with a regular and very similar cycle visible about every six minutes, which doesn’t appear to correlate with any activity in the other timelines:
    Node 2

    Node 1

I’ve reposted the above to the topic to highlight it.


No problem installing in the cloud but again I’m repeatedly seeing this error when installing client and node on my Ubuntu laptop (cc @chriso). From past experience eventually it will succeed so I’ll keep trying now and again.

afeup client --version 0.86.44
*                                    *
*          Installing safe           *
*                                    *
Installing safe for x86_64-unknown-linux-musl at /home/user/.local/bin...
Error: request or response body error: error reading a body from connection: unexpected end of file

Caused by:
   0: error reading a body from connection: unexpected end of file
   1: unexpected end of file


Hmm, when using a specific version, that won’t be a Github rate-limiting issue. It seems to imply there is some connection problem, but I would think that S3 should be a very solid place to pull something from.


Yay! A new testnet.



This is a recent thing for me. I have no issues using the laptop for http, ssh, scp etc.

Let me know if you think of any tests I could try to narrow it down. Also note that the download appears to complete before the error is shown.


Have to be Beta soon. I’d been thinking for a while you were running out of numbers lower than 1.0!


RealLife will stop me running any cloud nodes for a few hours.

Meantime here is a download to try

🔗 Connected to the Network                                                                                                                      Starting to chunk "sn-node-manager/" now.
Chunking 98 files...
Input was split into 161 chunks
Will now attempt to upload them...
Uploaded 161 chunks in 1 minutes 28 seconds
*          Payment Details           *
Made payment of 0.000001990 for 161 chunks
Made payment of 0.000000263 for royalties fees
New wallet balance: 99.999997747
*          Uploaded Files            *
"" 5a2ebb9377a9fe09dfd4462ccbe94bd0db9de4fbee8819bf4120cfaf1e1f40ff
"update.sample" 4944570eea5126916ba3076acc27dd22847fb067fae4c8446403d37d9cd461a8
"da35885d6496ccb7d0402f4b1a6c0ede8bda9d" ba6e8756947577176b362d14b1902ef9a1fb743c31f7caf3f3eac8feacf155ef
"post-update.sample" efa7027103d6cb6a0fbcc3ef6e105afbe7fd6cab612ea844181af2fc29c4b4e9
"HEAD" 5da6126f8f980736fcac72c3626c67e2b3cb03c1e201c68dad46f81f86c5c31a
"main" b8e8eb2c50b52c1dbe7653a6d77fadc6403e3f4bf1737834fa2ac2ca06cd33fe
"pre-commit.sample" b07128f893b1b0aa7285d02c40108db7e3968e13079c86b5c6405c376fa4a298
"424263408ad8c6118d5c03227df9561c981f85" de02f44dfd257f43cc0b743c1adf7bfbd1c030fbdb2f2f126c72c1f3d3bba1a3
"v0.1.2" 03c601ba0f32f5ba5545f289880c7ebbd9c82f50674a5254f75af3642c0eaa10
"5b9b69b0c17bd55701ddee2827ddee3aac78b7" 5a1a4c38f2ea1e4d6231f14168e518fc53c97c37405181343e39164584df2de2
"exclude" cea9d4bb398dbfdc5575538caddfb0f3dea8c414dfc9c8524df6509b2157df51
"fa7ab2354ee63c41b5c675efa4054dbede5437" b1bcfc3a1827dd34879debf110485ee3d50e769bc0b26642ddbfc3fd258bb98b
"Cargo.toml" 4644fb5c00461380d23c185daa67bee9c553a7775bf9aaa663dc218bdf05c8fd
"96fe68f3d88f3b528ae8c87fab2d003c55a415" 2f5d2597a45cbd290e9c61c081d13827635176390b0b5e6efc85473dc2a27522
"config" ea0a5a01f93d0c37f882463d9763cceeaceb30606f758a71750647add2605e98
"merge.yml" d92f251ab21378fe1664d474a9385781c5458386c3ff8bc7bbb03b9a71e592da
"v0.1.4" b8e8eb2c50b52c1dbe7653a6d77fadc6403e3f4bf1737834fa2ac2ca06cd33fe
"" 01f8fb5e36423dc0becda7fe72ac25343131c4711d460d5e2b0df1be84f71c0b
"65692791d59ef6c7e94945ca8749cd3f23b5f9" bc6b892a126171542eb241490f31659c598cc3449dd2757389aabfd4345ab679
"10435d7139d647f41b9ae89bf048c8687b2fd4" 4e961cd27f1116b42ca51973c2d8081186a3f6d75c58aea7fd22e7ef5e801c43
"HEAD" 892af9e2942b4594667da15918b33753f44bcfd8f4c1e893a0a65a36bb2ce68f
"72fedf785a3702e4ba68863600654543b4efee" 310770bf6c93a4ba33b5fa4ad9742e57591901831c692da5587b7a7b04f436b3
"2753c7e4efc6d436bb829771ce4257fdb53f5c" 0883a6a4c85d5bca8ab167d643135ebf75af8e5f6d665f3b775f97d172fd7a95
"ORIG_HEAD" c842941c8c5c3bd284fb025edfbc16d45bad2853385adc69d79cf718f9528ff0
"706f32a1073bb08fa8e98838f68e7fea36e17b" a4b33a0729d579ffc0ed7d632feebbe69c6363dc37625ff4533dbb67cf287d91
"91dcb8ea9c49cb66126989fbf35c4e80bc08ee" 3f61a13d38803b7d112ff6348ce73128539bbe3828a181e62ab738505d3155a8
"pre-receive.sample" 6761162a19d4006aad67e7db0ebe45098e66881adf6eabff68b88ac3953cd1f6
"" 9c3dcd797ce07056f2617f8d3aa4f7c3770fbf4fcd12ca859a3f1eea2429927b
"f95b43c186828c9b3bb7a8779bee7ae1487429" 571b627e96f0a723976a8d893e11104af88cfd008c0b82fa7e306eaae14f46d8
"release.yml" b98a712dde543868ee48a55f40e05bae23ef0a168c3b00fa31768f51d71cb86b
"5f9d61655871fc547b9e71b90922e8ab035d5d" dd75da8e48ff38d06fe8fd34b99ed7ec15756a37ae8ba04b61bf2255399bf4cf
"pre-push.sample" 68670231d33dd125fa601afb984f137200c078146a03248adf57c89af867e876
"" 9dd2790443edf12171eec182f117e6b619697c6ab507ed2f16c6b8fd788858e3
"922c055b6a7299313e17d78e750ad3d3782431" 858e53d8b668100d7aeae806239342aed2e2b9ecbd110d52c7279939a02fb945
"" ffc520ac97d723ecbc75da245ecee447e98afd236231d993f5a7eea0d16c605f
"82d9d2f643fbd0f7b2777e555a70490aef65d5" 35d0c9275d4846f1dd875ed5ca714b973f3e0eb44233129a1fc4d7f3bde2559d
"132a20f9b93d0d18c88db51158827795fbbca0" db0d4e3ea8dd1de8f8edb1b00112516d0bc79a6cc0ef09d2fe1e288d1f84f7a3
"main" b8e8eb2c50b52c1dbe7653a6d77fadc6403e3f4bf1737834fa2ac2ca06cd33fe
"" 2e022621bb7e0a437c911050b80e7795930d7b63af07c3c82e8916d823691eb1
"description" 4f7787748d2f5cf541de8bfa695f74585d20d441c5b7fa3bb327ebbce3deb9ff
"" 35f5a6d29175c4794f87a5d45bf5918b49b95e6e1952e770b4d805e7e6c7d661
"fsmonitor-watchman.sample" 8b5035d4a7bf4bbc7ff9fa011723b79fb868406ec2bda803887bff0d628896b3
"19d3916b0e5526dd56b4cd7a3d472cb29e8606" b329f883a29e6e026d32b85968fbd269f7d0d6323049fefd19ca97ae7516194f
"c08a7b051b352f5134ac37d5ea9dc24e639505" 00a8133958365e1ee678c4c6e65494d815ce3ef1a2f832a7979eb1959a6f3c96
"6e76bbb60ec476e6b86c0c57789acff3d5ab37" f287d13d4081bbbcda86ec5bfd609b8f5cce31bd499852875be0bd2240c01cca
"06292db6909846146778dcaf0e71edebd34775" 87e420517a2201313324aec7bdb7c72d0b9fc8f05e35b9c11247ea83fc8a3af8
"pre-merge-commit.sample" 5b7775eaab0e0ddbda2c6035400ed7776b0cae46c55bbbb06e841954fbdb5114
"d9020c8016a50adad4cb0d12f3aae3d4476312" d7e2e367ab7d8b6965352999b0d66531fc44b6decd2455489af9f2d078d6d42c
"4e1cfd4a508173cd762c928f9e9a0f92ed9c4f" 5f844b15a52c6009797520b5960546ed871ca61cf0668b766329ff18ec681239
"4d6249d9e69ea182a70be99d0bb28e412b51b1" bc4057d2ce2612c7ecc15a6ffa922a687ddf9e72aafbdd817474cbdff29585b5
"main" 9f1fda433fb8c9057e76a1839ce4e86de3ebed18a8117932b969c3964656968c
"faa8e0151595f341eec3223bdd46f04e110ebd" a60af02608753db7295536ab7bebfbd124eb59bfea5319b7ca1b9bf1d08d8c1c
"v0.1.3" bb2b761db8460986a6db09620b0050adfd1b78ff02ceeab49c6c29dd72814f08
"1a9fab74effffc1702ca5968a40713f08ec5d0" b98a6e90d76621b84b7a9e783542ad81eb96a3cdeeda05f639d8527b3e72d6ee
".gitignore" 46f2bc1689efcff7a41ab5803429afab0f20ee3111f86e9fa38fa0c0f6e9b340
"Vagrantfile" f338b58767d46800b54a31a2308c687c91daf2c85220b457c5139e25ce1e5dff
"3d328eb4f80a47d5cfc08dd97dda40f9bce3e3" b46ca95fca8c5f154624e1a42b002d1565cab4cff15201fd95bca093f6b473a2
"HEAD" 4270227c0ae7bb1897acf9f18b676af9a8ce202f5c56c224dda1ae5b18edefb4
"5db0ac72f5454386758879cf49ee375320d12a" c9aa20fd62e93a4da040e066b176d0603ed082bfdfdae474056f556a7498f4ef
"5ef6e0673d59b7b2387fae9e546d8ec27a2698" ae94950fdf4b03b3072b7bc90795fc16f81b17e051527dd95efd34851cef0b8b
"6486904839e97dcb94dd5b8475071cc25250f1" 586a547cae403d950932d6a252db671f7d8dfdb15e1b867d02621aa92ea43df2
"dcb057cc50bbc036c2f0a8eb2e3927ea103bf0" 5894ee9bc8f33734a6abcdf916fb8db454a3a467ba8c27a464448134fc5f10d9
"main" 4270227c0ae7bb1897acf9f18b676af9a8ce202f5c56c224dda1ae5b18edefb4
"packed-refs" cc5debd6fd47ea79c31cec5ace04dcd7d0b40cb7409daabc44b940b848d15591
"Justfile" 13648684ee9acffc3a2ae9b6dee9275e25492554e8f31e5242e3e9a5bf832164
"version_bump.yml" ec500f22bace6b7cb7c9fab62f80015b58ace1ed8567861c52063d530232a2b1
"670fabc736231172faee87a94911ff07c61094" abfe19730a02f3c8f98a8847db539314a02fb8eacf5866af3ca3d2bdbc4fbddd
"333ed7c67cf1fee9bb8dce8ea37388358eef32" 3c8e53c26ac7c762bd4f5f1c7c8c1148a6d584cac2acb8306773f04e24e83f02
"commit-msg.sample" f86a15da47642ae89116913f5355a61ad88e2cd620e655de242e1937a4d90720
"38339855afb50767d5505559b8840f43acad29" 790dea087abc25245c0a524545330a9c18079f53a4e057c4fdb608391904cc70
"bf926cd8d6df203271b7dc477179aef9eaa2cd" fb82514d1db50af6253b50ecc8716206f7cc768a367509ae2b2c6807e06be4ef
"53d1c9b51dc04cd15447d8e6bc3a5c6d23ca00" fb4e9f9f260cc48586af856ec1c06d8c71a6b1c145ba4e1135bd0c4232f8d70b
"" 0959bb26def658ad7570c72b16ba4cdce5a5bf6dd4f8049306feca299819cca9
"FETCH_HEAD" 47748c5f0f719cf926f469a80b54b2ca8e4cecbb8ba8f743e1455434056e6a8f
"0313ea4e135b55c1365718daa0e2d70c605c28" cea2ea8cebc276434dee12b63298f68ac8afc55d936be1ba9b17c08a6144aea3
"pack-707c331f78ab4c455c757506f8c19ead81b2057c.pack" d3fad326e391618a41400e127ec0945afb114012f76c2aa44ba60989f5c843fe
"652534dc13d6edd9931ca1cba36cd11eceed35" 514997be1fc397898c9363b29ce55068b57da095dfe14887ccd1ea36655a6f7c
"b34c6f5c59e6e72fbcfbd37d2352c78fd4a120" a728376c8121878589c7ef27f3a58d3fc82bec03b232e94000506a1d94a3f9f3
"d3b6561f376f3f5d09090de2b29dddd4ff749a" 1cf8e6da31f2ea21514af90ac9c169e1a69bda349e7bde5f197166c7692817c0
"prepare-commit-msg.sample" 50fa5437d83918c07255ac91c63ee9a0c2f4500c24ea6baade18bfe4340a6c9f
"150f806d21b2195c6c636f7c0cb99de7a8e359" af17dca630c2a3bca91c448344b801177a7147af92cdd6e76007ee3680156e36
"dfcebf2fc32083aa0416529a950f925d4f0248" 9c7eeb5437597054087fa1cc7601e4f0b3a9fd51cd2795b65c966322b1702d2d
"LICENSE" 7338123d2835278eef362badbefa589278bf87a460a4ab5b97839737642dabee
"pre-rebase.sample" 7ca141f29fb84253b343e547a072d1f1cfd54dc926f80de363252561223ad8fa
"defe445c68ad7cb6ddb00b629b6738c79bd9cd" 6c61bb067ffd38b8a2a2bb27288be38f786e8ee0d1b06d8d1d1383546db1ee28
"HEAD" e024d04cc7e27cb022d43cd28546420a7270b555523b89c88bfc84cf8e40cabe
"pre-applypatch.sample" 65f9d51279f4774ac9d35c211b768cd6a37aa866136963e4d8412bb50abdfadc
"push-to-checkout.sample" 88ca9e251ce84affe6e3676b16a0a6f7290e3571ff63380b81a2808d4e51ee91
"" 53c6509f8a503eef04699b96c3ab782ee18b8b6ab4f38dcb0292ae578c062b6f
"795f9617a66867c3ce25bae042bc3e17c59a52" 6383d2a42d8599e00c922620010a54bb68461b82e1aeac691f225945cf868139
"67b08304e0bd6eb02baa91e92a5c476984a327" 78a61608043d0d3fddce983726d3993cbbb43bc00f60cc6de2e6823c7f3a35a9
"index" fe5b1324729d3862646c45a3beff64e7ef45edac5537aadca082893ca28bdf6f
"applypatch-msg.sample" 9c3f4859e52fa7bb8ffd8fe308df64af41a84e767d6167278e9effd22afcd797
"4be70e1ad5ccfb42d7dd2d3c256cabf95d47b7" 3f9008e42c1c9f2959ba421b9c77a85b13a1924f56c72f81b9ead7d1989f1c8a
"7c6dc326f070b1c76b068c7fa756f320740a02" c6bfd27be93b381624ab8b35d80b4a73cae6b22bb6c53a1c03efa90050538bc3
"cfa816fd0adae0d5c2d0ec9e656405ec455151" 171f25daa00f9f20c427f61f34327bec429ba3fe5ce6eecd403eddeb6c8b55d9
"deeb5f6cf043f79b976bc7ce6bdd7e63928133" 5487ddb5049ef797450d6dbc80ec515797bd9997f8a6b6973db6781c726e14c0
"pack-707c331f78ab4c455c757506f8c19ead81b2057c.idx" ddd462bbf02a92e1eaf0a239f9e5a2e65e0db22d05f349e8cf580aa416caac66

Nodes up, early still but it looks like you guys have made some big improvements.



pre-commit sample and Vagrantfile? With your uploads you spoil us Mr Southside.


500 MB of random ones and zeros if anyone’s interested.

"500m" e2bf7cf5eec3c2e496b3a91c67fd32d53708ea20031954dd93306a88bde126ed


I have not tried running a node in months. It is failing for me right now. I’m at home behind NAT, is this expected right now? Easy fix in the future? Is there anything I can configure on my home network to make it work?

Logging to directory: "/home/tom/.local/share/safe/node/12D3KooWDZ7YhBKKCrA9Uh1pHbPXUumhKwAhVAf24q9Bmj85DHfG/logs"
Trying to fetch the bootstrap peers from

Node started

PeerId is 12D3KooWDZ7YhBKKCrA9Uh1pHbPXUumhKwAhVAf24q9Bmj85DHfG
You can check your reward balance by running:
`safe wallet balance --peer-id=12D3KooWDZ7YhBKKCrA9Uh1pHbPXUumhKwAhVAf24q9Bmj85DHfG`
Node is stopping in 1s... Node log path: /home/tom/.local/share/safe/node/12D3KooWDZ7YhBKKCrA9Uh1pHbPXUumhKwAhVAf24q9Bmj85DHfG/logs
   0: We have been determined to be behind a NAT. This means we are not reachable externally by other nodes. In the future, the network will implement relays that allow us to still join the network.


Backtrace omitted. Run with RUST_BACKTRACE=1 environment variable to display it.
Run with RUST_BACKTRACE=full to include source snippets.

No Me. blame @chriso

Its the latest sn_node_manager

Heres some Van Morrison

Uploaded 280 chunks in 32 minutes 52 seconds
*          Payment Details           *
Made payment of 0.000003707 for 280 chunks
Made payment of 0.000000505 for royalties fees
New wallet balance: 99.999993535
*          Uploaded Files            *
"03 - Moondance.MP3" 532bc2d0a88942886bea6671a1c23f0d5cc855415198ae5a4c03bd55ba0806de
"02 - Tb Sheets.MP3" 5d508888eee9bc162831bdaa8533d231a8b2dce09323f96e5d3814653864df65
"08 - Muleskinner Blues.MP3" cc40de2c1bde7f00b722e0adec180e47ff8208a07120509e16cc5f50c532c305
"10 - Just Like A Woman.MP3" d39b47c3db447d14f3b256b10002637d67062f5cd8aedb69c2974e8fb16ca036
"05 - Philosophers Stone.MP3" 325315c88a271593a756a1772772f61964f86f5a63d940bed6196ba7ba189d6b
"07 - In The Afternoon.MP3" 7abb8d9c0dedafb133d959790682252466ea5c32bbc6d141779aab52e24837a7
"06 - Centre Piece.MP3" 4d2c73396ef2c5c6e1235124889d71437d63589bc5a452b26eb524980189dc3f
"01 - It's All Over Now Baby Blue.MP3" 4cffd887d8f78f58e978f22bcdbf56f09ff841ccbf9b65bb05e2c6ea6e829401
"09 - Precious Time.MP3" fa8205c91f79f2d07291dc40f96b28d7bc1b825b4e91157a70a6073424b13fe8
"11 - Satisfied.MP3" e1b9198c71f0878ba121a6a33b0138462550977a2c015d0df358c2c94ae87977
"12 - When The Leaves Come Falling Down.MP3" 6e1fdef0e5d55f53aefdbd64aaac98a14b381722669c1345df31e4abb7654121
"04 - Back On Top.MP3" 96f60617dcff9daa20179305332099c3ea73a3e8664cb8974af3d5732c8f1575

You could perhaps try just using curl to pull the archive, which is here:

That’s where safeup pulls it from.

You could possibly try running that in a loop to see if you get any errors occasionally. You would need to check that it’s downloading the file correctly. Here is the md5sum:

❯ md5sum safe-0.86.44-x86_64-unknown-linux-musl.tar.gz
043385c5ec7e185e01352ea41d2bb9a8  safe-0.86.44-x86_64-unknown-linux-musl.tar.gz

I say this because sometimes it can download something, but it’s not the actual file you’ve requested, but rather, it’s just text and contains some sort of error message.


If you have public IP on your router you can setup port forwarding and run nodes no problem. Without public IP you are out of luck.


Which ports do I need to forward?


Even more useful if you post the md5sum for the file so we can see if it is a good copy.

1 Like

Ah, I think I see. I can start safenode --port 9999 and forward port 9999, yes?


Looks like the same error with curl. As you see, the progress shows it almost completes the download and fails very near the end:

curl -O
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
 94 10.0M   94 9652k    0     0   224k      0  0:00:45  0:00:43  0:00:02  195k
curl: (56) OpenSSL SSL_read: error:0A000126:SSL routines::unexpected eof while reading, errno 0

Again, but slightly different end point:

curl -O
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
 89 10.0M   89 9174k    0     0   219k      0  0:00:46  0:00:41  0:00:05  274k
curl: (56) OpenSSL SSL_read: error:0A000126:SSL routines::unexpected eof while reading, errno 0

…each time:

curl -O
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
 97 10.0M   97  9.7M    0     0   343k      0  0:00:29  0:00:29 --:--:--  389k
curl: (56) OpenSSL SSL_read: error:0A000126:SSL routines::unexpected eof while reading, errno 0


I have used curl for other things fairly recently but it isn’t something I use often.