Assemble at the Start Line. The Beta is About to Begin

I was brave enough to just go for the update to 0.108.3-alpha.2 without testing on single nodes first… And it took the nodes out that I use to produce this chart…

The network was and is fine - just my nodes crashing and restarting after finding the issue and the solution to it …



Unfortunately I didn’t keep a note of what the peers were. Just tried to add another node using 0.108.3-alpha.2 to get it again but I got:-

   0: Could not obtain network contacts from after 3 retries

so I’m guessing it is being worked on just now!

Or maybe it was just busy. Just tried adding a node with version 0.108.3-alpha.2

and this is the first peer in the list:-

--peer /ip4/

Tried starting it and got the same error:-

   0: Failed to start one or more services
systemctl --user status safenode24.service
○ safenode24.service - safenode24
     Loaded: bad-setting (Reason: Unit safenode24.service has a bad unit file setting.)

Can someone please explain what the issue is with ARM? I am running nodes on a windows 11 Surface pro 9 which is ARM and I do have nodes connected but with lots of errors and no nano’s received as of yet. Thanks!


In older versions of the Linux arm builds they were using a wrong key to send the collected coin to the discord bot (so he ignored them) - this is fixed now

But the latest version of the bot doesn’t ignore the default key anymore anyhow… So it’s not super essential to upgrade anymore…


Okay yeh, that’s latest contacts.

Hopefully it’s the service file issue, which should be sorted in a next release!

1 Like

There’s more DAG auditor fixes coming in today.

The current DAG has slowed again, we have another spun up which is ahead here and sees to be maintaining itself well, so once that’s integrated via the bot folk should see earnings pouring in once more. (Just trying to get more process established around all this so we don’t see a need to start fresh again as happened yesterday).

Thanks for your understanding here! :bowing_man:


I’m impressed how you always manage to find solutions. :+1:


I am seeing that once people have trouble they seem to continue having trouble even changing over to alpha. Standing back a bit we could imagine that certain IP address ranges are what is having trouble. Maybe the IP address of the relay node they connect to is what is being blocked too.

Could it be that your servers are behind intrusion detection/ddos detection of the datacentre and thus those ranges are being blocked or rate limited and so this is a cause of the problems?

Imagine someone trying to start 1000 nodes (or 500) and the DDOS/intrusion detecting system gets triggered because of the thousands of packets (retries etc) coming in fast and thick from that IP address and then the person trying this again and again. That could by itself trigger something


Good point, happened to me with 110 nodes, now running 50 on that vps.

1 Like

I wonder! I’ll write Digital Ocean and see what their chat is.

1 Like

Is there any way to see if your Windows launchpad nodes are actually making peer connections or if they just say “running” but aren’t really doing anything? Asked on discord, but not getting a response there.

1 Like

I finally made it onto the leaderboard: 80 nanos and position 42/167. So the DAG walking work has made a difference.

@joshuef 108.2 on Pi started fine. I’m running it without the home-network option and by specifying peers and I think it does cause more traffic because of being a relay. it seemed the 10 nodes I’d been getting away with at home were causing issues. Didn’t have time to actually check stats and had to just reduce to 5 to get good service back.


I haven’t tested on Windows but I think vdash will also work with the launchpad:

Privacy. Security. Freedom


Tested launchpad and vdash, working but you have to be aware of vdash limitations on windows (no refresh- you have to re-launch vdash to see new information about the nodes).


I haven’t seen that reported about Windows before.

He many nodes are you running? Too many will cause issues so it could be that.

Hi, one machine 10, second machine 10, third machine 30 nodes, the same issue. vdash not updating logs from files Windows 11 · Issue #26 · happybeing/vdash · GitHub

Using latest version of vdash 0.17.8


Any other Windows users seeing/not seeing this with vdash (not updating stats until you restart it)?

Some are using it on Mac too with no issue AFAIK.

Yes it’s the same for me. Only refreshes after relaunching vdash. Running 5 nodes on windows 11, same issue also on my windows 10 machine

1 Like

You can see networking in task manager for each node


Thanks, do you mind adding a report to the issue linked above? Any relevant info about number of nodes, OS and the full command line used to start vdash would be helpful.