Offline - One last Quicky (run 5)

sn_cli 0.39.2
safe_network 0.51.7

run 1 1vcpu-1gb-amd
run 2 1vcpu-2gb-amd
run 3 2vcpu-4gb
run 4 2vcpu-8gb
run 5 4vcpu-8gb-amd (amd is a premium droplet with newer/faster CPU and NVMe SSD)

rm -rf $HOME/.safe

curl -so- | bash

safe networks add comnet

safe networks switch comnet

Add a node
node join --network-name comnet --local-addr --public-addr 79.x.x.x:12000 --skip-auto-port-forwarding

test file
safe cat safe://hygoynyybh5bc3afb8i811wj8dnrpqkfx4mog9m3s1owokcz4763x5rhj9fko > spiral.gif



yes I did rm the existing spiral.gif


How is safe node join --skip-auto-port-forwarding --public-addr ip:port working for you?

It isn’t yet

willie@gagarin:~$ safe node join --skip-auto-port-forwarding --public-addr 9nnnnnnn5:35650
Joining network with contacts (PublicKey(155a..83b9), {,,,,,,,,,,,,,,,,,,,,}) ...
Storing nodes' generated data at /home/willie/.safe/node/local-node
Starting a node to join a Safe network...
Starting logging to file: "/home/willie/.safe/node/local-node"
willie@gagarin:~$ Error: 
   0: Cannot start node (log path: /home/willie/.safe/node/local-node). If this is the first node on the network pass the local address to be used using --first
   1: Routing error:: Cannot connect to the endpoint: Failed to verify our public address with peer
   2: Cannot connect to the endpoint: Failed to verify our public address with peer
   3: Failed to verify our public address with peer
   4: We did not receive a response within the expected time


Yes I got the same, I think will be allowed some “office” time soon :slight_smile: and can delve in.


➤ 849744… Bootstrapping a new node.
WARN 2021-12-22T00:22:34.326157Z [/home/runner/.cargo/registry/src/]:
➤ bootstrap {bootstrap_nodes=[,,,,,,,,,,,,,,,,,,,,]}
➤ Configured external port (35650) does not match that seen by peers (56148)

still looks like setting public-ip:port is no use cos safe node join just assigns a random port anyway @chriso

EDIT : command was RUST_LOG=safe_network=info,qp2p=info safe node join --skip-auto-port-forwarding --public-addr 9n.nn.nnn.nn5:35650

1 Like

Hmm, I’m not exactly sure what’s going on there. When I was changing the code for the node join command, this was how I was connecting to a remote network:

node join --network-name alpha --local-addr --public-addr 79.x.x.x:12000 --skip-auto-port-forwarding

This configuration worked for me. My router had a rule for UDP to forward anything external on port 12000 to the internal IP of my laptop ( I just have a crappy generic router direct from my ISP. Networking is not a particular expertise of mine.

The node binary seems to be aware of the port value you passed, so I’m not exactly sure where 56148 is coming from, or what that is exactly.


safe node join --network-name alpha --local-addr --public-addr 79.x.x.x:12000 --skip-auto-port-forwarding

that worked!


I’m in

ubuntu@instance-20211208-1104:~/safe-test-downloads$ Node PID: 3178, prefix: Prefix(), name: 6fba77(01101111).., age: 44, connection info:

does not seem broken to me


must try harder…

willie@gagarin:~$ safe files put 200MBtest 
FilesContainer created at: "safe://hyryyryyngjquzayra8u3r4zb1y1u1ckpfguu3z44xfs4d39cg6jpcdgb9hcyeuy?v=hgip1akd6y1eg5cnzxjfqayrb7yyyobuttozu3uwcoggpcnoq1aho"
E  200MBtest  <ClientError(NotEnoughChunks(191, 1))>

Cat spiral works.


what exact command did you use to join the network?

safe cat safe://hy8ayqyybtd67ug3q4fahx3p8ik7iir895f1zry7161fymkrxingukqsg95zo > pexels.mp4

safe node join --skip-auto-port-forwarding

Got a wide range of ports open, test instance so I don’t really care. I wish I could specify node chunks location (since I have a separate volume block mounted somewhere else), but looks like @chriso is onto it :pray:


Can you not just mount all of ~/.safe on that volume? or even ~/.safe/node?

I suppose I could… #lazy

1 Like

When I was messing with Pis I had ~/.safe/node mounted on a 1Tb external HDD formatted as btrfs

1 Like

Downloaded in just a few seconds.
Should I try and break it with a 600mb video?

1 Like

Small test video

safe cat safe://hy8ayqyyb7hjuz3hux6dqzzdx41r3g3ntzzreiywiuw3imcnnjt4zqubw7sco > file_example_MP4_1920_18MG.mp4