Initial Node UI: Starting with the terminal

As you know, we’ll be welcoming you all to the beta node olympics this summer. A big part of that will be lowering the barrier to entry, and getting nodes in as many people’s hands as possible.

We’ll be working iteratively to ease the friction around running a node, with the first target being eliminating the need for any knowledge of the command line to get things going.

This is still early doors, but we want to see how this feels, and for you to help us test an initial build of a text-driven interface that won’t require that CLI knowledge.

Over the coming days we’ll be giving this a handy build so users can download and use it like a typical app.

But for now, we are asking our intrepid community to build things manually, in order to test the interface for us. It’ll require sudo or admin privileges on your machine (we’re working to avoid that, a PR was just accepted upstream, so mac/linux will avoid this password prompt soon).

What is it.

If you grabmain branch of the repo and run cargo build --bin node-launchpad --release on your machine, and go to target/release in the repository folder you’ll see a node-launchpad executable! :open_mouth:

Double clicking this should do a few things.

  1. Open a terminal
  2. Prompt for sudo if it can.
  3. Show the node launchpad with some simple options for managing nodes on your machine.

Pressing the highlighted keys should manage background node services for you.

What it is not

A viable network! Don’t expect nodes started here to connect to anything at the moment. The main stable network is down while we address some alpha-punch issues. But soon you’ll be able to use this there.


On Windows you’ll need to run the app in admin mode. This should be possible via right click menu and " Run as Administrator".

On Windows you’ll also need to ensure you have this binary installed and in your path, and it also needs to be called WinSW.exe (not WinSW-x64.exe).

Trouble shooting

If cargo build --bin node-launchpad --release is a bit much for now, please sit tight, we’ll get you some pre-built versions soon.

Any other issues, please let us know and we’ll take a look ASAP!

What we’re looking for here

  1. Does double clicking to open work?
  2. Any other issues at the moment?
  3. What platform are you on?
  4. Other issues?

We won’t stop here!

We’ll be iterating on this rapidly (that’s why we need your help ofc), adding in the installer, smooth onboarding to the rewards program, automation to help out spinning up node… and of course stepping towards native interfaces as we expand the reach of the Network!


first! Time to read.

Will test this out on windows tonight, as I feel that’s the primary intended target… And my windows dope self was having issues running nodes on windows… :stuck_out_tongue:


Second - I’ll read the rest of it while its building :slight_smile:

EDIT: DO NOT USE THIS unless you have totally cleared ALL traces of previous safenode-manager activity

I plunged ahead with 20 STOPPED services on this box. I saw what looks like a very useable TUI pop up - and then another - and then another, THis went on for quite some time until this 32Gb box froze its GUI,

So Ctrl-Shift-F3 and login to a terminal - Eventually I got logged on and htop told me I had load averages >120. Much faffing about with pkill etc and the services kept respawning so for the first time in months, maybe a year, I had to forcibly Ctrl-Alt-Del to reboot.

so lets try again :slight_smile:


Please show screenshots.


OS: Ubuntu 24.04LTS

I have a local testnet running so built with --features=local-discovery in case it is compatible with node-manager services but it seems not.

I was able to start from the GUI by double clicking and it seems to display correctly, but all panels are blank.

When I press ‘a’ a popup overlay appeared and a message under the main screen showed saying “Created safe user for managing services” or similar. While I was writing this it appears to have shut down so maybe crashed.

Will try again from a terminal…

I guess this isn’t intended but for completeness starting from within a terminal creates a second windo with the TUI screen and the sudo prompt in the terminal. After entering the password it shows an error:

Trying again using the GUI to launch…

Now shows an error immediately, perhaps because it has already run once and created the user from the first run.

Trying again, without local-discovery

Seems borked. I get the same result as immediately above (launching from the file manager).


1 Yes - oh boy does it work…
2 Many - trying to present them coherently in a min
3 Ubuntu 22.04 Ryzen 3600 32Gb
4 Dunno yet - but the knowledge of Ctrl-Alt-F3 etc to escape an unresponsive GUI helps

Tried again – I was a bit quicker this time but I still had to close 132 unresponsive windows. I will try to get a screenvid



My box is locked up again. Had to log on here from my phone.

1 Like

Seriously recommend you pull this for now if my experience is anything like everyone elses.

1 Like

Revenge on the hammer lord? :joy:


Beside having to “rustup update” for Rustc, this was pretty easypeasy for me at least even the A adding and S starting nodes was pretty easy.

I can see me easily installing this at family and friends their house, only issue is how to auto start their node back up after a computer shut down. I can’t tell if you can spin specific nodes back up.


Hell yes. I am about to delete a 8GB syslog that just filled /var/log…
My box is truly gubbed for now, cant get past the GUI login on reboot.
If I was not mildly competent with CLI Id be totally effed with a ragmans trumpet

More later. Must get to the shops now


I had a go on windows 11 and didn’t get very far.

downloaded the binary and changed the name also added the folder to path.
when click run as administrator it prompts for permission then the terminal closes and that’s as far as I got


OK @19eddyjohn75 - you are the only one reporting ANY real success

What is your OS etc?
Cos I am having no fun whatsoever on Ubuntu 22.04


Iterate, baby, iterate…


Hmm, when I used the TUI in a little Ubuntu VM it seemed to work OK.

This was before the TUI attempted to launch a terminal. The original design was to have two separate binaries: the TUI and the launcher, where the latter would launch a terminal and then run the TUI inside. It turns out though, on Windows and macOS, if you just run an exe that is meant to run in a terminal, both of those OSes will automatically launch the terminal for you.

Btw, my preference for the TUI was for it to be part of safenode-manager. So if you ran safenode-manager without any arguments, it would boot into the TUI, but you could still use the CLI as normal.


Did you have WinSW.exe somewhere on path?

Ubuntu 22.04.3 LTS

I love it to say something clueless, turn off my computer, turn it back on and click on target/release/node-launchpad and see my three puppies still running. Amazing to see the nodes still running :grin: :beers:


@chriso what part of the code would cause the unstoppable spawning of so many terminal instances? I ran a quick w | wc -l while in the Shift-Ctrl-F3 terminal and over 400 lines… mostly root

1 Like