Fleming-testnet - Error: Cannot start node due to error: Routing(TryJoinLater)

On ‘node join’ I get the following error in sn_node.log:
Cannot start node due to error: Routing(TryJoinLater)

I have tried ‘node join’ every 10 minutes for the last 30 minutes.

The network only allows new nodes to join when it requires new nodes. If there isn’t enough data been uploaded then the network doesn’t need new nodes.

This is an attack prevention I believe. There is a script you can run on you command line to automate the retry. I ll see Ifni can find it for you.


I was trying to launch node every 5 seconds for the last 15 hours → same result.

Here’s an improved version from @wydiliei:

until grep -q "Handling NodeDuty" ~/.safe/node/local-node/sn_node.log; do safe node join; sleep 30; done
1 Like

I think on the next iteration of the test net this retry will be automated. @dirvine in future testnets willi it be possible to create high churn on the maidsafe nodes to allow more people to have a chance of creating a node?

1 Like

I’ve marked your post (above) as the solution, the log message should say this instead of implying a routing error.

I think you will see better log messages in the coming releases. This first release was rushed out as a proof of concept. The Devs will be working on tidying stuff up in the coming weeks/months.


Check the folder /home/xeon/.safe/node/local-node to verify if you have chunks. Even if you are already an active node if you run the command the message remains the same.

1 Like

It’s worth noting something here. With all this in place even MaidSafe cannot start/seed with any more than 14 nodes without filling them/getting more data loaded up. That flattens the MaidSafe supply of nodes and we are then like all community members, our nodes wait to join, but we are not aggressively trying (every few mins). Some folk will emulate bad guys in the run (good) and try every few milliseconds and likely beat our nodes.

This is a good position we are in, not tweaking (just for the testnets) or adjusting and it’s important as it let’s us see all aspects. One thing we have not done is close down the fact you can create coins out of thin air, but we will close that door too, but right now UX is not clean enough for folk to earn coins or give the each other, although the latter should work now.

tl;dr we will see as much of the real network as possible in these tests and the network is gonna treat us all as potential attackers :wink: It’s better this way I feel as tweaks and side effects are misleading.


I start new sn_node process only if old one exits.
If it keeps restarting it means that my node is not activated.

Of course as it should be. Thanks for explaining.

1 Like

Does this error mean at least it is successfully connecting to the safenet but is being turned down for a connection.

Its not an error that appears if there is no connection possible.

Yes that’s right. We are about to make a change this week where no node will ever be turned down. Although some may not be connectable from other nodes they can connect. So it’s an issue if they became Elders, but any node can be an Adult, they just need to to make sure an always be connected to their Elders.

This will allow 100% participation connectivity wise. Right now this cannot be Elder restriction is not in place, but will be in next iteration.

If a node is on for a while and prevented form being an Elder then it’s owner will be earning nicely. IF they have no direct connection or IGD/UpNP etc. then they can manually port forward. That is a small hassle but at that stage of earning, it won’t be an issue I reckon. Not doing that means you keep earning though.

I think this breakthrough is vital, to have 100% participation to me is really important.

tl;dr if this network keeps splitting it will likely fail in weird ways, but that is cool. The fix is simple and will allow 100% participation. Those poor kids in poor countries are gonna get a chance here.


Using the script referenced by @Guybrows, the node eventually joined the network, it took approx 3 hours.

Screenshot below showing node join after getting the ‘Routing(TryJoinLater)’ error in sn_node.log


Good stuff. Glad you got joined

1 Like

Well done on joining.

I’ve been running that script over night - no luck.

edit: i am in now!!! :partying_face: :partying_face: :partying_face: :partying_face: :partying_face:


fyi - it took me 10 hours to join when trying at 20 sec intervals

1 Like

Look for chunks.
It may be that you join, but nothing happens next (hang):

See chunks screenshot below.

1 Like

That is zero chunks.
cat chunks/immutable/used_space will return 0 if I understand correctly.