Can't see how to use Safe Launcher (to upload files)

I have got the Safe Launcher connected but can’t:

  1. associate it with the demo;
  2. see how to upoad files
    I should be most grateful for help

which version of SAFE Launcher do you have?
which operating system are you using?

The latest version - downloaded yesterday.
Ubuntu 16.04
(thanks for your reply)

did you login or create an account?

Yes - created an account - with the two passwords - and have successfully logged in.
Had to open another terminal to download the safe demo - is this possibly the problem?

so nothing happens when you open SAFE Demo App?

downloaded from where? or GitHub?

I have gone through the process of downloading the SAFE Demo App - had to open a second terminal to do this - but can’t open it

downloaded from

I don’t have the terminal command to open the Demo app.
To open SAFE Launcher I use " safe_launcher " ( in the terminal ) - but the command to open the Demo app must be in a different format - “safe-demo-app” does not work; neither does “safe_demo_app”

OK so you installed SAFE Demo App using sudo apt-get install safe-demo-app? if yes, you need to run it using safe_demo_app. This is a limitation of the current release and will be fixed in the next release.

1 Like

Indeed, yes - I used sudo apt-get install safe-demo-app - but can’t open it - have tried “safe_demo_app” and got no result. I think I will start again and repeat the process and then come back to you if unsuccessful?

for me safe_demo_app works fine on Ubuntu 16.04. so yes I would recommend trying again :slight_smile:

Many thanks for your patience - I do appreciate it and your time.

1 Like

Solved the problem !!
Many thanks for your help - very, VERY much appreciated.
Have a great day!
Duncan (in Scotland)


Interesting follow-up: can open safe-demo-app on my 64-bit pc but not on the 32-bit one - both running Ubuntu 16.04 Does this make sense?

SAFE Demo App should work fine on a x86 machine (32-bit) running Ubuntu 16.04. I don’t have a machine I can reproduce this on. Can someone from the community please confirm if it works for them using Linux Debian on a x86 machine while following the instructions here? :slight_smile: (using sudo apt-get install safe-demo-app)

It is indeed strange. I have checked (by searching) that the file
(safe-demo-app) did indeed download (it did) - but typing in
“safe_demo_app” just doesn’t open it (it does, as I say, on my other pc).
I have made the appropriate adjustments to network settings and to Firefox
extension setting - no difference. Strange.

What error do you get? Or does nothing happen at all? I only have x64 so I can’t check.

error message:

safe_demo_app: command not found

and same message when I enter “safe-demo-app”

Another person has mentioned that he thinks there is a problem - and that
the devs all have 64-bit computers so have not been exposed to this.

It is not a major issue because I can access it on my 64-bit pc - I was
just interested in solving the problem. However, no doubt there are others
out there who only have 32-bit computers and they may also have the problem.

Just in case you are interested - to give you some context - I am a
recently retired health-care worker - aged 67 - and am relatively new to
Linux - this should explain why I seem such an idiot!

Many thanks for your continuing interest and patience!


1 Like