SAFE Network - Test 15

It is our pleasure to be releasing Test 15. Here are the changes compared to Test 12c:

  • Fixed the crust timer overflow bug.
  • Use SHA3 everywhere instead of SipHash.
  • Several merge and tunnel fixes, and additional tests for merging and tunnels.
  • Nodes now try to reconnect after a connection drops.
  • Fix the bug which created an empty log file when timestampping was set to true in log.toml.
  • Allow users to force include TCP acceptor port in connection info via new option in crust config file (force_acceptor_port_in_ext_ep).
  • Indicate to routing if the remote peer, which is trying to bootstrap, presents itself as a CrustUser::Client (in which case external reacheability check will be subverted) or a CrustUser::Node (in which case external reacheability check will be mandated).

SAFE Vault v0.13.2

Only people who either have a TCP port forwarded and specify it in their crust config file OR people who have UPnP enabled will be able to participate as a Vault.

If you forwarded a TCP port on your router (see this website for more information on how to do this), you need to specify the port in the safe_vault.crust.config file (which is located in the same directory as the safe_vault binary) in the tcp_acceptor_port field.

You can run only 1 Vault node per LAN – running more than 1 will result in this message:

More than 1 routing node found on LAN. Currently this is not supported


SAFE Launcher v0.10.3

To connect to Test 15, you need to use SAFE Launcher v0.10.3.

Each client account is limited to 500 PUTs. A PUT is a request to store a single chunk on the network (a file may contain many chunks). The maximum chunk size is 1 MB.

Please be aware that we might need to restart this test network, wiping all data that is stored on it. We will announce this in a Dev Update (when possible) prior to taking it down.



SAFE Demo App v0.6.2

The latest version of SAFE Demo App (v0.6.2) should continue to work fine.

When uploading files using SAFE Demo App, the maximum file size is 25 MB per file.



SAFE Browser v0.4.3

The latest version of SAFE Browser (v0.4.3) should continue to work fine.


Other apps

Apps that were working with TEST 11 should continue to work fine with TEST 15.


If you need help with anything related to SAFE Vault, SAFE Launcher or SAFE Demo App, please use the Support category of this forum.

Where should I report issues?

If you know which component a bug is associated with, feel free to report it on GitHub in the corresponding repo.


Great work guys can’t wait to get this up and running


Time to get tore in again :slight_smile:

Thanks for all the hard work that went into this, muchos appreciados hombres.


Here some video to test: safe://opm.draw.
ps: the 1st seconds of the video not moving is caused by the conversion.


Nice work!



#Updated ABC for running a vault from the cloud:

Goto SSD VPS Servers, Cloud Servers and Cloud Hosting -

+Deploy New Server/Instance
+Vultr Cloud Compute
+[Any location]
+[Ubuntu 16.10]
+20GB SSD $2.50/month
+[scroll down and enter a server hostname]
[deploy now]

get IP address and a copy of the password

from your computer then login via ssh with the ip address and password just copied

ssh root@999.888.777.666

Logged in via ssh


and do this:

mkdir ./SAFE
cd ./SAFE
sudo apt-get -y install unzip
unzip ./
cd ./safe_vault-v0.13.2-linux-x64
[Enter x2]

wait a while… for resource proof…“This will take at least 300 seconds.” <410s… ta da! :thumbsup:
detach from screen and leave it running with

“Ctrl-a” “d”

“exit” will drop your ssh connection and the vault will be there when you ssh again, running in screen.
Use “screen -r” to return to the screen with whatever is the latest output from the vault.

Any questions, just ask but it’s simple and worth doing for the experience of running a cloud server.


Not able to run the vault. I guess my speeds does not deliver expectantly. I’ll have to wait for another day.

All works fine for me, except upon restarting the vault. Then it just crashes. Does anybody have suggestions for what may be wrong?

EDIT: I use uPnP

Might be your port, that really needs to be open. So port:5483 should be open in both your firewall and router.

Thanks for the advice! Maybe I should look through the settings even more thoroughly this time.

1 Like

I also use UPnP, with port forwarding disabled.
This works without a problem for me (on Linux Mint), also after a couple of vault restarts, before and after approval.


Now I successfully corrected the port forwarding settings. However, I still get the same error, where it just closes down upon restarting. Maybe it has something to do with the fact that I am both port forwarding AND using UPnP?

Maybe post some logging so that people of Maidsafe can look at it. But I’m pretty sure it isn’t because you have UPnP and port forwarding enabled at the same time. That was no problem for me.

Are you just failing the resource test?
What error do you see??

If it is instead the Launcher, then that’s a different kind of problem. It’s more usual that you would want to see the Launcher connecting; use the Browser; and then the Demo App for creating a website. Vault attempt follows success in seeing the Launcher connect to the network.

1 Like

First when I tested the softwares, the launcher, demo app and the web browser all worked. Then I tried starting a vault several times, all failing to restart the vault. I will post the log-file very soon. However, I do also want to mention that now the network seems VERY unstable to me. I am frequently getting the error where both the launcher and the demo app fails to connect to the network.

[EDIT:] The log-file can be located here: safe://home.leik/Node-1490302729.log


D 17-03-23 20:59:15.718586 [routing::states::node] Node(9cddc9…()) Received LostPeer - PeerId(04ef101f…)
I 17-03-23 20:59:15.718586 [routing::states::node] Node(9cddc9…()) Dropped 9daa09… from the routing table.
T 17-03-23 20:59:15.718586 [routing::states::node] Node(9cddc9…()) Scheduling a RT request for 30 seconds from now. Previous rt_msg_id: None
D 17-03-23 20:59:15.727605 [crust::main::active_connection] PeerId(253bc545…) - Failed to read from socket: Io(Error { repr: Os { code: 10054, message: “En eksisterende tilkobling ble tvangslukket av den eksterne verten.” } })

The Norwegian appears to suggest a run of “An existing connection was forcibly closed by the remote host.”

Close to that you’ll see the like of

0/12 resource proof response(s) complete, 8% of data sent. 380/410 seconds remaining.

You appear to be simply failing the test and perhaps more quicker on repeated attempts, if in some way nodes recall your previous fail.

Terminating state machine

perhaps could do with being more clear that the test was failed.

Try a cloud node as detailed above?


Also if you run the vault test against the launcher and/or demo app, you should expect those to be slow, as the test appears to involve upload and download volumes.

I see no issues from here…

Yay test net 15 is out! But why are we still using github given the updates to their policy?

1 Like

One problem at a time :slight_smile:


The usual suspects as speed tests: