SAFE Browser 0.10.2 hangs in tabs opening a save: site

Newcomer to SAFE, I installed the browser from
trying to open one or other of suggested sites


Tab hangs forever (> 60 min).
What am I missing?

1 Like


Could you try with the latest browser, which you can download from here?
Don’t select the ‘-dev’-version.


Hello draw,

I just installed peruse from Peruse-v0.7.0-osx-x64

It says “Attempting to connect. Check your network connection, then verify that your current IP address matches your registered address at

Should I create a SAFE account first?

1 Like

If you want to only view static websites, you don’t have to register/give an account secret and password.
If you want to also test the ‘dynamic’ sites, you have to get an invitation in order to create an account. To get an invitation, you have to have to read 1 hour on this forum. You’ve already read 20 minutes, so 40 minutes extra to go :slight_smile:
An overview of sites on the Alpha 2 network: List of Websites/Safesites & WebIDs (Community Resources).

1 Like

Thanks, draw.

I tried to open in Peruse several sites listed, such as safe://cat.ashi - hoping that this is a static website.
The peruse page says ‘Setup Incomplete. Connection not available yet.’ after I close the orange warning banner.

I will eventually proceed towards getting an invitation.

Is Peruse intended to replace the SAFE Browser?

Yes, and I think you’ll need to go to the invite server and click ‘Set IP address’ before you can access anything.

This has to be repeated if your address changes or to will get the same issue. Good luck, and welcome :slight_smile:


safe://cat.ashi is a static site and it works for me with the ip adress on not matching. Maybe some firewall is blocking outgoing tcp port 5483 (see peruse.crust.config), but I could be mistaken and it could be another problem.
Edit: did some more testing and the static website now it indeed doesn’t work (most of the time?) when the IP addresses on the invite website don’t match.


OK, I’m not sure what the issue is then, if the IP doesn’t need to be set except for authorised access.


Trying again Peruse - logfile shows repeated attempts to connect -

T 18-11-25 18:51:02.100663 [<unknown> <unknown>:49] Creating unregistered client.
T 18-11-25 18:51:02.101074 [crust::main::service] Network name: Some("alpha_2")
T 18-11-25 18:51:02.112528 [crust::main::service] Event loop started
T 18-11-25 18:51:02.112659 [crust::main::config_refresher] Entered state ConfigRefresher
T 18-11-25 18:51:02.112772 [<unknown> <unknown>:537] Waiting to get connected to the Network...
I 18-11-25 18:51:03.167783 [crust::main::bootstrap] Failed to Bootstrap with (ClientNotWhitelisted) Our Client is not whitelisted
(many similar entries...)
E 18-11-25 18:51:03.183078 [crust::main::bootstrap] Bootstrapper has no active children left - bootstrap has failed
I 18-11-25 18:51:03.183119 [<unknown> <unknown>:269] Bootstrapping(c6ebf3..) Failed to bootstrap. Terminating.
D 18-11-25 18:51:03.183149 [<unknown> <unknown>:403] State::Bootstrapping(c6ebf3..) Terminating state machine
T 18-11-25 18:51:03.183268 [crust::common::core] Graceful event loop exit.
D 18-11-25 18:51:03.183675 [<unknown> <unknown>:37] **ERRNO: -2000** Unexpected("Could not connect to the SAFE Network")

copied from


ok, so I also tried under windows 8 64 bit and Linux Mint 17.3 and I get the error:
‘Setup Incomplete. Connection not available yet.’
By updating my IP on it works!
@rudifa I’m sorry you can not see my cat … it’s really the most beautiful in the SAFE Network :frowning:


All right, now I see your cat. Beautiful.



I am trying to access safe://cat.ashi with Peruse 0.7 on OSX but I only see Requested public name is not found. Any ideas?

(I don’t have an account yet since I’m still trying to get to trust lvl 1)

1 Like

Wait - what is the difference between Peruse dev and non-dev? Is the reason why I cannot view the site above that I downloaded the dev-version, and it does not connect to the alpha network?

Do I need both dev and non-dev?

I am confused

1 Like

@maidsafe Please tell us if you need to have lv 1 and set ip to browse Alpha 2?

You don’t need both, but the Dev version needs the --live command line parameter if you want to connect to the live network. See:

Pretty sure you don’t need level 1 or an invite (because you don’t need to be logged in), but you may still have to set your IP.

You can not specify ip address without lv 1…


OK, then I would say you do need level 1, but don’t need to be logged in. That seems to fit the data we have.


This topic was automatically closed after 60 days. New replies are no longer allowed.