Routers for advanced setups

These are mine, they started about 10 min ago as well. Pretty sure I’m on the latest version this is on one of my windows pc’s the ubuntu pc’s are still starting up.

How do I check my version?

The raspberry pi looks good so far

1 Like

That looks OK to me, sometimes for no rhyme or reason I have similar to that, other times they are all 3 digits.

I’d leave it and see if they earn.

1 Like

hey do you have a way of tracking your nanos? Vdash isn’t good for alot of nodes right?

This is the exact pattern you get when connections are being dropped a lot.

It must be happening somewhere. The trick is to isolate it.

First thing is to test with 10 nodes and see if the pattern happens on that device, then 50 and increase of decrease from there to find the highest node count for that device.

Then you can get your other device and have it start up nodes and see if the pattern returns on that device you were having trouble with

All the programs have --help
and I expect all have the --version too, but --help will tell you which options gives version if its not --version

1 Like

yea it looks like not using the node-port but home-network seemed to solve the issue I’ll see if i get nanos in a day or so still at 0

1 Like

Still if you want to isolate the problem then you have to do testing with small number of nodes and keep increasing till you see the peers see saw problem appear.

Then the max nodes the setup supports will be less than that point since it builds up. No needs to wait days between raising the number of nodes, just increase wait 20 minutes and check then either increase again or stop if the pattern appears.

THEN from that information the issue can be further isolated once we know the number of nodes it supports.

The next step is to set the number of nodes to 10% less than the problem point. THEN start nodes on another device through the same router and see if the effect starts up on the device you have problems with now.

FROM that we gain a lot of useful information even if it doesn’t seem so.

Those 2 lots of information will provide the information to know how to pinpoint the issue.

Yes home-network is a solution but you should get more performance with port forwarding or UPNP if you wanted to use that instead of port forwarding.

One thought, did you set the IP address of your devices connected to the router in the DHCP reservation section of the router??? if you didn’t then its the most likely reason the port forwarding isn’t working for you. But most likely doesn’t explain the see sawing of peers

yea I couldn’t really get past 20 or 50 nodes without losing peers but even then on my raspberry pi’s I had only 15 and 20 nodes and they both were losing peers then gaining then losing again.

and I’m not sure I had this guy on fiverr configure everything, but i’m looking at my dhcp and there is like 6 IP’s there so I think he did.

how would I setup upnp? Do i just have to add nodes with upnp or do I need to configure something in the router?

also what would the benefit be for having more performance with upnp would I generate more nanos?

Thankyou this info say its either the router or ISP itself. And you cannot rule out the ISP

its a rule in the router
Then using the --upnp option of the safenode-manager

over port-forwarding - it means you don’t have to setup the rules in the router to forward ports and the ports aren’t always open to your PC, even the ones not currently being used

Over home-network - less errors on the nodes, potentially the ability to run a couple more nodes because the cpu usage is not as much

But with your current situation it doesn’t mean much


now with you current situation, if you run more than the 20 or so nodes then the nodes are losing connections and definitely being shunned by a lot of nodes, but they cannot contact you to tell you since the connection was dropped. So a silent death by 100 cuts. And obviously no way to earn than by sheer luck

2 Likes

ok so if I wanted to run with upnp all i have to do is use the --upnp when adding nodes I dont need to set anything in the router correct?

UPNP has to be enabled in the router! If it has it. Most do.

I have to say that I didn’t manage to get it to work from a friend’s house that has a basic router which apparently has UPNP that we switched on. I don’t think that’s the fault of the node as plenty of other people are using the upnp option. I think it’s the awful router he has.

So I just setup the 5 nodes with --home-network.

Read what i said again, I did say that a rule has to added to allow upnp

ah ok yea I wasn’t understanding what u meant, now I do thanks

1 Like