Initial build on ubuntu 14.04, errors building experCommon

Im just getting started, I have followed the build instruction on github
The results are on the CDash under maidSunburst, common.

I ran the experCommon build.

After looking around the common error phase looks like.

/build_maidsafe/boost_1_57_0_GNU_4_8_2/tools/build/src/tools/gcc.jam:121: in gcc.init from module gcc
error: toolset gcc initialization:
error: version ‘4.8.2’ requested but ‘g+±4.8.2’ not found and version ‘4.8’ of default ‘g++’ does not match
error: initialized from

This was found in file …/boost_chrono-build-out.log , but it is in all error logs that I looked at.

I have done this on two machines over the past 2 days and progress has been made figuring out paths etc but now I’m stumped. It looks like some kind of tool versioning problem but I have gcc 4.8.2. I checked everyway I know of.

Im coming back up to speed on SW engineering. I have taken a few years off so boost and github etc are still sorta new. Im still figuring out who does what to whom. :smile: Im new to maidsafe but Ive picked this as a project to get going again. It sounds so promising and needed by the world.

1 Like

Can you provide steps you’ve done prior to the error?
And the exact version of the OS (14.04 or 14.10)?

@alpinekid This is a known bug and a fix is currently working its way through our workflow.

Here is the version info. Im working on reconstructing exactly what i did

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04 LTS
Release: 14.04
Codename: trusty

$ uname -a
Linux maidSunburst 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Thanks you. Im still learning how to use git effectivily. What should I look for the tell when the fix is in and how do I update? Thank you for your time.

Looks like you did the git side fine, we are all learning :wink: . I am mobile just now, but there is a JIRA bug for this which once you set yourself up you can automatically track progress on - I will look it up and post it here next chance I get. Once the fix (pull request) has been merged you can:
git checkout next git pull git submodule foreach 'git checkout next && git pull'
This will pull all the latest updates from the next branch to your local copy

Thanks, In the mean time,is there anything useful I can or should be doing. There is a lot to read on these forums.

This is the bug I mentioned - you can create an account and track it if you wish > [MAID-753] - JIRA
A good place to start is here >

Thnaks I’ll do that

@alpinekid The Arch fix has been reverted (and another bug created to work around this :wink: Make error building on Ubuntu 14.04 - #6 by BenMS ), so if you pull the changes as I oulined above you should be able to build Common and run the tests now. Give me a shout if you still see issues.

Thank you, I have made it a lot farther. :smile:
My first attempt didnt show any change. I found that in addition to incantation you provided above, I had to do a make clean before make ExperCommon.
Im guessing that the dependency tree in make didnt see the changed file that corrected the problem but I dont know, Im guessing. I’m still very much in high speed learn mode. My hyperlight-speed drive is not fully spooled up yet like the rest of you folks.

I now have two test failing, TcpTest.BEH_UnavailablePort and

I will investigate and start a new topic. This ones seems fixed.

1 Like

Cool - You can see your results here >
If you click on the test(s) you can see it failing on other platforms / compilers / etc these are known issues and are on the list to fix. If you explore the dashboard you will also see that the build is currently broken and this is also being worked on by the team. Thanks for your help and please continue to investigate!

1 Like

@alpinekid welcome to the elite (ahem, looks askance) band of community folk who have a working build! …well almost :slight_smile: Well done!

We really should have a community badge for this - I wonder if discourse supports custom badges. We could have a medal ceremony and… [a long arm appears stage right, grips @happybeing firmly by the shoulder and pulls him out of sight… short pause, tiger roaring sounds]

1 Like

Thanks, Im working my way up the stack, This morning I build passport and rudp sucessfully.
An error in crux and im building routing right now.

Not sure what I can do with it all when I get to the top. Do I get to run app? Lifestuff maybe, not sure what that is. Or become a node on the test net? or ???

I do need to readup on C++. Its been a long time since I coded and things have changed. I took a look at crux/test/socket.cpp, that is where the error was when I build, and I really need to do some studying:-) I have coded a ton of C but not much C++.

Is the “list to fix” posted someplace so I dont waste people’s time posting things that everyone knows about?

There’s not much useful stuff you can do yet - no app, the testnet is up and down so you may be able to join it and watch this happening using the visualiser (I’ve done that), you can also start a local testnet (not very exciting) and run the tests.

It means you can keep more up to date and get to know how it all fits together.

i had trouble builing said I needed submodules, then downloaded submodules and now I have a bunch of junk in my home directory which I read after the fact should…
anyway hey these are all written in c, is there a build module for rust? when will that be coming out