Help please - How can I get the Safe Browser up and running


I’ve been trying to get the Safe Browser running and have been having hours of misadventures.

(Ubuntu 16.04 - Odroid XU-3)

So far I’ve:

  • downloaded the tar.gz
  • tried
    • tar xvzf safe_browser-alpha-2.tar.gz
    • ./configure
    • make
    • sudo make install
  • Followed the README. md instructions included in the download
  • Searched the forums and google for advice

It is possible that the browser has been installed and I just don’t know how to start it. I wasn’t able to find any info on how to do that.

I’d really appreciate any help.



Sorry that I say this, I’m allergic to command lines



in this example you can just download this and extract it, sorry I can’t explain how the tar.gz works. When you click on the icon it should just work, I’m windows indoctrinated.

If you don’t have an invite yet go here to get an invite token:
Set your ip and your good to go on these sites:
Outdated: Alpha 2 Community Websites, Apps & SAFE Messaging IDs

Good luck hope it helps, I can’t help with command lines



No command line is good for me too :slight_smile:

I tried wasn’t able to get that to work. I did download and extract the folder. I can’t figure out how to start the browser from there though.

There is a file called “safe browser” that looks promising. But when I double-click that it just created another file titled “p[@q�@8 (invalid encoding)”

I might try on another computer.

I probably sound like a grandpa, but

I always click on that purply safe-browser thing :smiling_imp:

Hopefully somebody more capable can help :stuck_out_tongue:


Oh, yeah that is the one that made the strange file in the folder.

Well, the browser works well in another Ubuntu 16.04 pc just as 19eddyjohn75 said above. Thanks!

It seems it just isn’t working with the Odroid XU3 and it’s arm processor.

1 Like

Yes, you would need a build specifically for ARM. This can be done but the current Maidsafe builds don’t support ARM.

1 Like

This topic was automatically closed after 60 days. New replies are no longer allowed.