Github or Maidsafe problem?

So I decided to break out my collection of SBCs (including the older Pis donated by @aatonnomicc - muchos appreciated) and finally get a proper subnet of all my SBCs together.

Finally find the correct memory card for the first one and get started. Then a sudden halt…

safe@bananapi:~$ wget
--2023-03-24 20:52:28--
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: [following]
--2023-03-24 20:52:29--
Resolving (,,, ...
Connecting to (||:443... connected.
ERROR: The certificate of ‘’ is not trusted.
ERROR: The certificate of ‘’ has expired.
The certificate has expired

If I am reading this correctly its a GitHub problem but before I make a potential arse of myself on GH I thought Id ask here.

1 Like

So I worked around this with

Re: [SOLVED] - wget fails with certificate error for github

Post by vhar » Thu Oct 14, 2021 4:57 am

Create ~/.wgetrc file and add to it

and now I have the latest release downloaded to the first of my SBCs.

But why have I never had this problem before?
I dont have a ~/.wgetrc file on my x86 desktop box.


Github refreshed their SHA key today. The secret key was put into a gh repo and they created new one. I suspect that was your issue there.


This topic was automatically closed after 60 days. New replies are no longer allowed.