Fleming Testnet v3 Release - * NOW OFFLINE - v4 RELEASED*

My first node connected! :open_mouth:

I can see blobs being stored and everything! :sunglasses:

In previous NAT tests last year, I couldn’t connect a node, so it looks like this latest version likes my router.


yes, I pinged it. 87 to 89 ms times.


I’ve got 23 megabytes of chunks :grinning:


Did someone create safe://lazydog before me? I tried to create it and it said it already existed! :slight_smile:

I can dog it, but it is taking a while to cat. I’m excited to see what it is now! :rofl:


All, if you post an error please state the OS you are using.


auth restart does stop and starts it even if it couldn’t stop it

1 Like

UBUNTU 18.04.4.LTS

safe cat safe://hygoygyenxp3e516x1uktohmzxd3w8ubcnr9rhcd97xrjfsf4pztn5gbynw > Toivo_through_bottle.jpg
Error: NetDataError: Failed to GET Public Blob: SelfEncryption(Storage)

as wrong as it sounds…love the feeling of chunks coming through!

[sn_node] INFO 2021-04-15T22:31:05.821653+10:00 [src/node/handle.rs:27] Handling NodeDuty: WriteChunk

[sn_node] INFO 2021-04-15T22:31:05.821752+10:00 [src/chunks/chunk_storage.rs:65] TRYING TO STORE BLOB

[sn_node] INFO 2021-04-15T22:31:05.821821+10:00 [src/chunk_store/mod.rs:100] Writing chunk

[sn_node] INFO 2021-04-15T22:31:05.825181+10:00 [src/chunk_store/mod.rs:104] consumed space: 1048604

[sn_node] INFO 2021-04-15T22:31:05.825245+10:00 [src/chunk_store/mod.rs:105] max : 2147483648

[sn_node] INFO 2021-04-15T22:31:05.825300+10:00 [src/chunk_store/mod.rs:106] use space total : 4194416

[sn_node] INFO 2021-04-15T22:31:05.845263+10:00 [src/chunk_store/mod.rs:125] Writing chunk succeeded!

[sn_node] INFO 2021-04-15T22:31:05.849660+10:00 [src/node/handle.rs:27] Handling NodeDuty: No op.

[sn_node] INFO 2021-04-15T22:31:24.551889+10:00 [src/event_mapping/mod.rs:44] Handling RoutingEvent: MessageReceived { content: “000500…”, src: Section(2f9253…), dst: Node(2c1d4b…) }

[sn_node] INFO 2021-04-15T22:31:24.578632+10:00 [src/node/handle.rs:27] Handling NodeDuty: WriteChunk

[sn_node] INFO 2021-04-15T22:31:24.578760+10:00 [src/chunks/chunk_storage.rs:65] TRYING TO STORE BLOB

[sn_node] INFO 2021-04-15T22:31:24.578901+10:00 [src/chunk_store/mod.rs:100] Writing chunk

[sn_node] INFO 2021-04-15T22:31:24.581849+10:00 [src/chunk_store/mod.rs:104] consumed space: 1048604

[sn_node] INFO 2021-04-15T22:31:24.581886+10:00 [src/chunk_store/mod.rs:105] max : 2147483648

[sn_node] INFO 2021-04-15T22:31:24.581917+10:00 [src/chunk_store/mod.rs:106] use space total : 5243020

[sn_node] INFO 2021-04-15T22:31:24.608169+10:00 [src/chunk_store/mod.rs:125] Writing chunk succeeded!

[sn_node] INFO 2021-04-15T22:31:24.612002+10:00 [src/node/handle.rs:27] Handling NodeDuty: No op.


auth create --test-coins gives me

AuthdClientError: [Error] ClientError - Response not received: read error: connection closed: timed out

EDIT: If there is nothing in my sn_node log I am accepted as a node?

On both laptop and desktop machines I get a similar error trying to start sn_authd
I have stopped all safe and sn_authd process and nuked the .safe folder

willie@gagarin:~$ safe auth start
Error: Failed to start authd

Caused by:
    AuthdError: Failed when invoking sn_authd executable from '/home/willie/.safe/authd/sn_authd'
willie@gagarin:~$ /home/willie/.safe/authd/sn_authd
sn_authd 0.5.2
SAFE Authenticator daemon subcommands

    sn_authd <SUBCOMMAND>

    -h, --help       Prints help information
    -V, --version    Prints version information

    help       Prints this message or the help of the given subcommand(s)
    restart    Restart a running sn_authd
    start      Start the sn_authd daemon
    stop       Stop a running sn_authd
    update     Update the application to the latest available version
willie@gagarin:~$ /home/willie/.safe/authd/sn_authd start
Starting SAFE Authenticator daemon (sn_authd)...
[Error] GeneralError - Failed to start sn_authd daemon '/home/willie/.safe/authd/sn_authd' (exit code: 1)

What trivial mistake am I making?

Ubuntu 20.04 and 16Gb RAM on both machines

I get the same error if I try to get that file.

Are auth and authd the same? Both exist? Just guessing…

1 Like

Well that was too easy!

Just for fun and to make it more difficult, I’m running it all through Tor :wink: lol … amazingly it’s working !!

Edit: It’s probably the mission impossible (network) music running in the background.


You have to add and switch network first.

I was able to get it



Ah OK I was just following the instructions in the OP

I’ll try that TYVM :slight_smile:

And it works – thank you @Traktion

We need to get the OP changed then and move safe auth start to after the networks section


I read it too rapidly and I understood it as your lazydog was a cat!


I’m the worst sometimes. What command do I use to watch my logs?? Trying to start a node before I go off to work. @StephenC that might be a good command to have in the user guide for noobs if there’s room for it.

1 Like

He’s right here next to me… he looks deeply offended! :rofl:


I am still not able to get it. Weird. UBUNTU 18.04.4. LTS

safe cat safe://hygoygyenxp3e516x1uktohmzxd3w8ubcnr9rhcd97xrjfsf4pztn5gbynw > pullopollo
Error: NetDataError: Failed to GET Public Blob: SelfEncryption(Storage)

Some context:

  1. I am putting it again at the same time. But I was not able to get this file even before.
  2. I have another cat process running in another terminal

Question: are the cat processes in my system activity monitor these cat’s of Safe? There is two of them running now.

Now I have to go. I’ll be back after a couple of hours.

1 Like