Community1 test network 18-hour run

Now that Testnet5 is winding down, and Testnet6 is scheduled for tomorrow, that leaves a window for reactivating community1 with some new backend tweaks. Basically, I have eight vaults running on the cloud server, as well as one locally. More than enough to run client apps, nice and fast:

The theme of community1 is “The Bleeding Edge Community Network” and its distinction is to host the very latest builds of the SAFE network software.

For the convenience of participants, I have assembled the configs and binaries into four variations, at the link below Please download one, probably “community1-amd64-release” if your computer is a regular PC running 64-bit Linux, and run one instance of it. No modifications or additions are required!

Please also run the launcher and upload whatever you like.

“Release” is the official binary as used in Testnet5, while “latest” is one that is automatically compiled nightly straight from the github repo:


For other OSs and for the launcher, get the appropriate config from here and drop it into your Testnet5 folder:

Stats for the seed vault are here:


I understood it differently. Test 6 this week but not tomorrow.

Of course the plot is just for one instance, I haven’t implemented an aggregation of them all to show such things as the complete number of client connections.

Cockpit shows stats of server health (not sure why network is flat):

That’s a Celeron processor, by the way.

1 Like

He did say it would be released tomorrow. No harm if it goes a bit longer, though.


I have a vault running. tried to upload my site but after a few minutes of sitting at 0% I received - cannot connect to launcher, launcher should be kept running, or something like that. (launcher was connected)
going fishing I try again in a bit.

I’m running the demo app and launcher from Testnet5, with the config in the OP, and it worked fast. Just now created a new site: http://another-test.bluebird.safenet Each step took a few seconds (granted that they are just “hello world” pages. Sorry, fake spiders!)

1 Like

OK, I was having the same problem as @Josh so I have reconfigured my vaults so as to eliminate the “–first” vault, which I suspect, from previous experience, can cause instability (or not), by (tl:dr) musical chairs.

Seems rock-solid now. Please try again!

And you will need to create your account again, as I did, since taking the vaults down wiped everything. I have reloaded my websites: http://test-community1.bluebird.safenet/ http://another-test.bluebird.safenet/

Let’s see how long it lasts, since I won’t be touching it again tonight.

Doesn’t seem to be working

I found a problem with the network and it is now working. Please try again.

hi bb,


vault on is running nicely and i think you are fine to add this ip to the config as i use it each time now.

vault on is throwing the good old:

Running safe_vault v0.10.2
ERROR 09:54:11.653160162 [routing::core] Disconnected(0822fa..) More than 1 routing node found on LAN. Currently this is not supported

have restarted os, etc etc… same result…

do you have a tweaked version i can grab that has this nonsense removed?


That’s excellent, thank you! I’ve added it to the configs.

I wonder that encouraging a bad habit of accepting recompiled binaries, might not be a good idea, regardless of who those are from.

Tweaks and recompile are too easy to encourage, relative to the risk later when currency and privacy is involved; and then obvious other risks beyond what the network should do.

A community network surely should follow directly from what was made available for each Test or in future Alpha. Those folk who then want to do something else, can know how to do that but obviously any change will potentially add confusion to performance.

Adding in a new network config that is human readable, is trivial and at least worth understanding for all those wanting to know how to switch networks.

Perhaps shortly community network will directly follow from each new instance of the network released from Maidsafe but even then there is a risk of putting new binaries around as if they are necessarily ‘SAFE’.


OK, then if you are concerned please use the alternative method of running the release package from Github with the community1 config substituted. Thank you.

By the way, the binaries offered in the OP are straight compiles of the Maidsafe repo. No editing whatever has been done. There are no “tweaked” binaries being offered here.

1 Like

Could you point me to the current community1 config file for the launcher please?

Here they are, as in the OP:


OK working now, thanks. Vault is up to routing table size 9 but the chunk store only contains 26 chunks after 30 mins or so. Is that expected?

1 Like

Excellent! Yes, only if people are uploading a lot will you see much in the chunk store.

1 Like

I’m finding that after a few hours the demo app won’t connect, despite the fact that the launcher connects in a few seconds. I’m going to try a slightly different approach that will require a restart (and brief downtime) of the vaults on the cloud server, in a few minutes from now.

EDIT: It’s back up now. I now have the startup script write the (parent) PID of each instance of safe_vault to a text file. I can then track them individually in Htop and kill and restart them one by one, instead of all at once. I had found that you can’t rename the binary: it simply won’t run with any other name except “safe_vault”, so it was hard to know for sure what I was looking at in Htop with twenty or so lines all saying “safe_vault”.

Now, when I see the demo app getting stuck, I’ll introduce some “churn” by restarting vaults one at a time at spaced intervals and see if that helps (while aiming to preserve IDs and data).

The relevant part of the startup script, for the first two vaults, looks like this (where $! is the variable for the PID of the most recently started process):

cd /opt/safe_vault0/
./safe_vault >/dev/null 2>&1 &
echo "0  $!" > /opt/safe_vault-pids.txt
sleep 5
cd /opt/safe_vault1/
./safe_vault >/dev/null 2>&1 &
echo "1  $!" >> /opt/safe_vault-pids.txt
sleep 5

and so on.

The resulting text file looks like this:

0  11207
1  11216
2  11225
3  11234
4  11243
5  11293
6  11343
7  11352
1 Like

Although launcher connection takes a few seconds, upload of a website can take a couple of minutes even if it is a minimal site of a 100 bytes. So if you are experiencing time-out then try the least amount of data first.

1 Like

mine are back up… if you had that jabber account i would have known much earlier!! :wink:


INFO 16:45:52.517154894 [routing::core]  --------------------------------------------------------- 
INFO 16:45:52.517220313 [routing::core] | Node(7572ec..) PeerId(fe5e..) - Routing Table size:  11 |
INFO 16:45:52.517262041 [routing::core]  --------------------------------------------------------- 


INFO 16:45:55.993671747 [routing::core]  --------------------------------------------------------- 
INFO 16:45:55.993682745 [routing::core] | Node(9bcf8d..) PeerId(cc2b..) - Routing Table size:  11 |
INFO 16:45:55.993691170 [routing::core]  --------------------------------------------------------- 


1 Like