Building the vault

I’m quite new to compiling my own binaries but over the last few days I gave it a try. Viv was kind to help me out a bit over PM but as I run into some new trouble I wondered if anyone could help me out.

Here’s a link with instructions. The idea is to install Rust and use the GNU compiler instead of the MSVS (microsoft visual C) as that ones gives trouble. I’m on Win 10/64. I’ve installed both requested programs and afaik my paths are right:

One of the problems that shows up while compiling is the request for DLLs. I’ve found some more info in their repo about Cargo being broken for Win64. There’s talk about a DLL I’ve seen today as well.

I’ve tried to use the nightly build as well:

After this I proceed with installation.

This is what I get after I download the Vault repo from GH and try to build the thing locally:

Here’s where it all stops:

Does anyone has a clue? A workaround? Would be cool to build the vault myself.


Missing VCRuntime140 normally would just point to needing to install the Visual C++ Redistributable for Visual Studio 2015. Your env variables however seem a bit different to what I got for msys, just to try:

  • Open up command prompt
  • try gcc --version . I’m expecting this to maybe fail with something like gcc not found
  • run set PATH=C:\msys64\mingw64\bin;C:\msys64\usr\bin;%PATH%
  • run gcc --version this should give you something like:
gcc (Rev1, Built by MSYS2 project) 5.3.0
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

if it does, then try a `cargo clean && cargo build --release`
1 Like

Going through the instructions on my end to see what happens.

I was having trouble the other night with rust_sodium because the libsodium sight was down. Doesn’t seem to be the problem right now though.

1 Like

You are right, did run your path settings and afterwards it did respond with version info etc. here’s another bug I just got, I saw this one earlier as well.

Compiling serde v0.8.23
Compiling lru_time_cache v0.4.0
Compiling winapi-build v0.1.1
Compiling rustc-serialize v0.3.22
Compiling accumulator v0.5.0
Compiling unicode-width v0.1.4
Compiling kernel32-sys v0.2.2
Compiling ws2_32-sys v0.2.1
error: linking with link.exe failed: exit code: 1
error: linking with link.exe failed: exit code: 1
= note: “link.exe” “/NOLOGO” “/NXCOMPAT” "/LIBPATH:C

These are the last few lines:

Build failed, waiting for other jobs to finish…
Build failed, waiting for other jobs to finish…
error: Could not compile kernel32-sys.

Not sure I followed this, but yes after running set PATH=C:\msys64\mingw64\bin;C:\msys64\usr\bin;%PATH%, you’d expect gcc --version to return output like what I pasted above.

Do note setting PATH like this is not persistent. So once you close command prompt and open again or open new window, you’d have to set it again. You can either edit the env variables from UI or just use setx PATH "C:\msys64\mingw64\bin;C:\msys64\usr\bin;%PATH%" to have it persistent.

My guess is your rust installation is still msvc based. Once you get gcc --version to print the output than the error, I’d almost install rust for windows-gnu again for 1.14.0 and try a fresh build so cargo clean && cargo build --release and hopefully should be sorted.


Thanks Viv, great help :+1:


Nope, just downloaded the .zip from the repo and got it working without any further changes.


This topic was automatically closed after 60 days. New replies are no longer allowed.