Safe Firefox Addon freezes Firefox on Ubuntu (VirtualBox Desktop)

I’m assuming that since you pulled it from the page that it’s the one that was updated and noted in the lastest dev update. That update also goes into some details about adding unsigned addons in FF43, but it doesn’t seem that you had that problem.

There’s a couple things about the addon last I checked - the max amount that can be uploaded is ~1GB IIRC, and some further gotchas. The update (and links to other discussions) goes through the setup as it was then. I doubt anything significant has changed.

HOWEVER, all that being said, I too had trouble with that pesky addon even in Debian Jessie as well as Fedora 22 & 23. It was a huge PITA and I’m not quite sure that in the end I ever really solved it.

The one time I did get it to work was when I was running everything mock, and uploaded only the demo page. That’s the only time that Firefox didn’t totally shit its pants when I tried to get it working.And I’m talking about the pre-compiled binary, don’t even get me started on compiling it from source.

I mean, if you like node.js, have at it, but I won’t be the one that can point out what’s going wrong where. My only helpful piece of advice is to run FF from a terminal, and see if you can catch any helpful error/debugging output.

P.S. I’m pretty sure that the vaults as well as FF are intended to be ran on the same machine. If you haven’t done so yet, try it that way as well.

EDIT - RE: Compiling from source:


1 Like