Nope, it was a misunderstanding (Test 17: for the people who aren't "trust level 2")

EDIT: So this my hypothesis of what happened. I used the invite and that seems to have whitelisted the IP of my school. Therefore now the kids in my school can download and brrowse the safenetwork without signing up.

Just wanted to point out that even if you aren’t trust level 2 and don’t have an invite, you can still browse SAFE sites without creating an account.
So even though you won’t be able to test out the demo apps such as hosting, mailing and generating a public ID, you can still browse sites without signing up.

So, if you want to try it out, go ahead, download the SafeBrowser and visit the sites around!

  1. Downlaod the latest version of SafeBrowser: Release SAFE Browser 0.3.0 · maidsafe/sn_browser · GitHub

  2. Browse around a few of the SAFE Sites:


I just downloaded the newest safe browser and am running it on its own, but can’t seem to visit any of the sites. It just keeps loading.

1 Like

no error?‌‌ ‌‌ ‌‌ ‌‌

1 Like

same for me tralalalala 20 chars

1 Like

Still loading. No error yet. I am using macOS Sierra 10.15.5

Are you sure it is supposed to work without the authenticator?

1 Like

what do you get if you go to:

1 Like

You have to download the Safe Browser I linked here.
Must be version 0.3.0

Same thing here. Just sits spinning.

you have a few lala’s short. copy paste the link instead of typing them


unfortunately still the same

have you tried with the other sites?
like safe:// ?

It should be working without the authenticator, I tested it in my friends computer who wanted to try it out without an invite.

1 Like

I did download it from the link you posted.

safe://lalalalalalalalalalalalalalalalalalalalalalalalalalalalalalala.lalalalalalalalalalalalalalalalalalalalalalalalalalalalalalala is no different, just keeps loading.

Btw, I agree with you that the new logo for the browser needs to change. The shadow messes up its symmetry like you said.

1 Like

That wasn’t me haha
I never said anything about the logo

yup same thing, doesn’t load just keeps spinning. Tried in an ubuntu vm as well.

Oh, my bad :slight_smile: Anyway, I agree with whoever mentioned it.


huh, maybe this is what is happening. My friend accidentally was able use the SafeNetwork, because when I activated my invite it whitelisted the IP address of the whole school haha.

Sorry for the misunderstanding.


I just earned my level 2 access so all is gooood :slight_smile:


Several more replies and I’ll be there as well :slight_smile:

Creates incentives for higher collaboration & communication. This system is effective


I get 2 different behaviors, one is that the chrome launches and loads an address and the other is when the windows app store pop up comes up and says Could not find an aapp to open this type of file (SAFE)