"Core error: Unexpected: Could not connect to the SAFE Network" Can't create an account to use the Browser

I have tried repeatedly to create my initial account but I keep getting the “Core error: Unexpected: Could not connect to the SAFE Network” message.

Any suggestions?

1 Like

set your IP address at invite.maidsafe.net


Thanks. I’ve already done that step. I was issued my token id and went through the create account steps but still the “Core error: Unexpected: Could not connect to the SAFE Network” message.

1 Like

So your registered IP is the same as your current IP at invite.maidsafe.net?

Yes. They are the same

What OS are you using? Also what version of the browser?

0.6.0 on windows 10 …

Hmm - tried that combo and it works for me. Here’s the standard procedure.

Step 1: log onto the forum using your usual web browser, e.g. Chrome
Step 2: go here https://invite.maidsafe.net and click on the icon
Step 3: select Alpha 2
Step 4: select update IP (if the two IP addresses shown are identical you can skip this step)
Step 5: click on the clipboard icon to copy the invite code
Step 6: start SAFE Browser and follow the steps to create an account. When asked, paste in the invite code

Doesn’t have to be in that order necessarily, but that should work.

If it’s not that I don’t know really what to suggest. you could try the latest version of the browser Releases · maidsafe/sn_browser · GitHub


Check your firewall is not blocking the browser.

And does your (router’s) external IP address end in 204?

Well, thanks. I followed exactly those steps. Current and Registered IP button is grayed out but IPs are shown. So I have no option at that point to select update. Also, I use 4G LTE to my desktop to get online. Would this come into play?

Firewall seems ok. And, yes my IP ends in 204.

1 Like

This guy had problems using a wifi tether router - could that be it?

Hi Mark,

Thank you for reporting this.

I’m curious to know if any helpful information may exist in your logs.

When you have the time, will you please, in SAFE Browser menu, click on File -> Show SAFE Logs, then paste the contents of your logs in a reply post?

@ustulation Does the establishment of peer-to-peer connections require a different protocol on a mobile network NAT(4G LTE) compared to landline and cable networks?
Although that hasn’t been shown to be an issue anyway with the testing of maidsafe/safe_mobile.


Ok. Got on using VPN.

Hunter, Safe Browser, File, Safe logs = “Filelog is empty”

Hi Hunter,

Im facing the similar problem. Im currently working on my office wifi.

Here are the logs from authenticator.log:

T 18-01-09 18:12:35.244543 [safe_authenticator::ffi mod.rs:58] Authenticator - create a client account. T 18-01-09 18:12:35.244936 [safe_core::client mod.rs:242] Creating an account. T 18-01-09 18:12:35.447971 [crust::main::service service.rs:556] Network name: Some(“alpha_2”) T 18-01-09 18:12:36.452054 [crust::main::service service.rs:82] Event loop started T 18-01-09 18:12:36.452223 [crust::main::config_refresher config_refresher.rs:44] Entered state ConfigRefresher T 18-01-09 18:12:36.452392 [safe_core::client mod.rs:1393] Waiting to get connected to the Network… I 18-01-09 18:12:46.459472 [routing::states::bootstrapping bootstrapping.rs:287] Bootstrapping(a69ee3…) Failed to bootstrap. Terminating. D 18-01-09 18:12:46.459519 [routing::state_machine state_machine.rs:418] State::Bootstrapping(a69ee3…) Terminating state machine T 18-01-09 18:12:46.461842 [crust::common::core core.rs:91] Graceful event loop exit. D 18-01-09 18:12:46.462435 [ffi_utils::catch_unwind catch_unwind.rs:53] ERRNO: -2000 CoreError(Unexpected error - CoreError::Unexpected::{“Could not connect to the SAFE Network”})

Can you help me?

Yes, let’s get this fixed for you.

Have you covered the basic steps?

Is your office wifi based on a mobile (cellular network) tether?

1 Like

Same problem here. But I’m trying to connect from office so error is definitely proxy related. Is there a way to set proxy parameters on SAFE Browser?

a lot of thanks, been having the exact same problem as OP, haven’t yet treid your method though so hopefully it will, work. may i come back with questions if anything? again thanks!

Hi - you need to be Trust Level 1 before it will work (you just need to do a bit more reading on this forum).

Hi, I have the same problem and same log. I am trust level 1.
I have the newest version installed. Working behind proxy and firewall. But this is usual for the most users in companies. If you work for a serious company they will never open ports in the firewall! So, how can I use SAFEnet in b2b scenarios?