Safe Network Dev Update - December 17, 2020

I suspect one day vdash will tell you off for this. Well done for spotting it. Things like that can illude for days in the world of code!


Certainly don’t want to distract the MS team from getting on with their work, but does anyone from the community have a video of ‘stuff’ working, no matter how simple/technical/raw, that they could share?


@happybeing it’s worth saying. If we’re missing logs in some decent place. Or you think the format / naming of the messages is off. We’re toootally open to PRs / suggestions adding / tweaking logs / messages here.

Right now the log levels aren’t super consistent. But it may also be worthwhile us getting into some specific debug logs just for the events we care about in nodes, things vdash may be wanting to know about.


Thanks @joshuef, I’ve replied here: Vdash - Node dashboard for Safe Network - #37 by happybeing


This is very simple but it shows the local network set up, auth, etc.
baby fleming


Many thanks Savage!


Curious difference in the speed of transactions. In the first ones, most of them took a couple of seconds.

But after a certain point the processing time increases and now they take about 10 seconds with a much higher CPU consumption.


I noticed something similar with PUTS and syncs


Yes we have not profiled any of this yet, there are likely a couple of recursive methods and perhaps even some loops at play. We will squash those though. It’s just been the massive codebase changes and frantic get it all shoved together to prove everything that means we will have “silly” bugs. This next part is much simpler, code tidy, handle errors properly and profile. It’s great the community help us so much and the team are brave enough to “warts and all” it wherever possible. A good combo


Is MaidSafe working till the 24th or will next update be tomorrow?


We are still going, we may put out a small update, but don’t count on it. There are only a few of us working and I would prefer we keep bug hunting on the testnet for now. Let’s see what these next couple of days brings though


Hope you guys take your time to relax and be with friends and family too! What you’ve done for the safe network / humanity this year is admirable, my deepest respect.


New versions of our CLI, sn_node and authd applications have been just released. For those actively testing this baby-fleming testnet, it’s recommended to update them all since a few of bugs reported in this thread have been already resolved.

One issue we discovered was in the CLI update command, thus you’ll need to re-install CLI rather than update it. You can do this by following the instructions in the download section of the User Guide, e.g.:

$ curl -so- | bash

With the latest CLI v0.17.0 installed, you can re-install authd and sn_node, or simply update them with the following two commands:

$ safe auth update
$ safe node update

Once they are all updated, the local testnet can be launched again as usual, and as described in the original post. You can find details of some of the fixes included in this release of CLI v0.17.0 here.


Not tried yet, but I believe the updated vdash v0.5.1 will correctly report PUTS and GETS with this updated safe CLI v0.17.0. You can update vdash with cargo install vdash or if you’ve not got it yet install vdash from scratch.


As usual Windows isn’t playing ball. Here’s the error on trying to create a Safe:

C:\Users\John>safe auth status  
Sending request to authd to obtain a status report...  
Safe Authenticator status  
Authenticator daemon version             | 0.0.13 |   
Is there a Safe currently unlocked?      | No     |      
Number of pending authorisation requests | 0      |          
Number of notifications subscribers      | 0      |                                                                                                                                                   
C:\Users\John>safe auth create --test-coins        
Sending request to authd to create a Safe...  

[2020-12-23T16:55:18Z ERROR safe] sn_cli error: [Error] AuthdError - [Error] ClientError - Unexpected: Could not connect to sufficient elders.

I’ll try on a different machine in a bit. Has anyone succeeded on Windows yet?

That may be a problem with the network not fully formed/bootstrapped, perhaps retry with killing all nodes ($ safe node killall), and starting the network again? (this doesn’t seems to be platform related).

1 Like

Different one now (after restarting)

`C:\Users\John>safe auth create --test-coins                                                             

Sending request to authd to create a Safe...                   
 [2020-12-23T17:20:21Z ERROR safe] sn_cli error: [Error] AuthdError - [Error] AuthenticatorError - Failed to store Safe on a Map: Data error -> Unexpected error: Cannot send zero-value transfers`

Did you make rm -rf ~/.safe?

I have several errors before deleting all the previous data. After that, work fine.

Yes I had a good cleanout before I started. I often have problems on this particular machine, so it may be something very specific to my setup. I’ll try a different one after a few more attempts.

Edit: It’s working now :+1: I found some old Maidsafe stuff in Appdata and got rid then restarted everything. No idea if that’s what solved it, but I’m on the road.


@happybeing Latest vdash builds in Windows using the --features=crossterm flag, but it seems to be static, ie it takes a single snapshot of the logfiles rather than displaying the data in realtime. Is that to be expected?

Edit: Deja vu - guess I need to set the log levels before launching the network. Vdash - Node dashboard for Safe Network - #9 by JPL

Edit: working