Masterchest 0.4

I downloaded the new masterchest wallet 0.4 and it’s showing my maidsafe coins! The downside…It says I don’t have enough bitcoin to pay the fees required to transfer them. Anyone know what the fees are? I looked everywhere and couldn’t find any info.

Thanks for the update!
I may be wrong, but I believe the fee is the standard Bitcoin transaction fee of 0.0001

*EDIT: yeah I was wrong. I checked my own balances and have 0.0001 BTC available on one of my address with MSAFE but it still says I don’t have enough available. This is definitely ALPHA. :frowning: *

looks way too alpha to be honest. Have you read the disclaimer?

I’ve got .00044 and it still says I don’t have enough to transfer :frowning:

Weird. 0.00044 should be more than enough for fee. Fee was 0.000168btc.
Probably to be safe, u would need 0.001 btc in your wallet to transfer maidsafecoins. Come on, thats 45cents :))

According to the MaidSafe Team,

0.00023 BTC shall be enough to complete a transaction.
However, if you may have to wait for the BTC balance to be fully confirmed (6 confirms),
and no other transactions happening at the same (can only handle one transaction at the same time).

And, the BTC amount must belong to the address holding MSAFE .
Most of BTC wallets show balance including those hidden “change address”. Which means although you see there is enough fund in your wallet, it might be belongs to those change addresses, meanwhile the address holding MSAFE doesn’t have enough fund to complete a transaction.


I was able to transfer my SPT (MSAFE) to my another BTC address. It was scary, but it worked!
Can you see me dancing? (Hops happily)

My total transaction fee was 0.00029. Another member on said their fee was only 0.000168. There is disparity between fees. I don’t really know why that is, but at least it works. I recommend a minimum of 0.0003 BTC when using Masterchest v0.4. The SPT balance will not update on until the 6 confirmations are done.
Keep in mind, it’s still in ALPHA.

Just thought you guys should know.


Arrrrgh! I bought 0.1 bitcoin hoping that would more than cover transaction fees and fix everything. Now, my masterchest wallet is not synchronizing :frowning:

This is the error I’m getting. Someone else posted this to mastercointalk today too. Anyone else having this problem?

[2014-05-21T11:23:41] DEBUG: Block Analysis for: 301947
[2014-05-21T11:23:42] DEBUG: Block Analysis for pending transactions
[2014-05-21T11:23:42] BLOCKSCAN: Transaction processing starting…
ERROR: Blockchain scanning thread threw exception : There was an error parsing the query. [ Token line number = 1,Token line offset = 46,Token in error = FROM ]
[2014-05-21T11:24:06] DEBUG: Thread exited with error condition.

FWIW, I posted on mastercointalk and github. No help yet :frowning:

I’ll keep you guys posted!

I sent the exact same error to their support email.

Will update if I hear anything back.

masterxchange not working now either, a number of people having same issue - once 2factor auth entered, page just goes blank.

"Hey guys,

The creation of the first fixed SP issuance in the MSC ecosystem
unfortunately triggered a bug in Masterchest Wallet due to a poorly formed
database query.

This bug caused each scanning thread to terminate before completion and
thus leave the wallet in a ‘Not Synchronized’ state.  The following would
have been visible in the debug panel:

ERROR: Blockchain scanning thread threw exception : There was an error
parsing the query. [ Token line number = 1,Token line offset = 46,Token in
error = FROM ]

I have corrected the issue and pushed build 0034 to GitHub.

Please note, the .NET wallet project has now been moved over to the
foundation, and the new official foundation GitHub repo for the project is

You can download build 0034 here"


Yeah, I think I’m going to wait a bit longer before attempting to move my maidsafe coins. It’s an amount significant enough to me to not play with alpha version software :slight_smile:

1 Like